Anchors away... why won't they work (again)?


(John Goodnough) #1

So I’ve read through all the prior posts regarding anchors in Rapidweaver and I can’t understand how something so basic to web page design is so difficult to get working in Rapidweaver. I wish I understood code well enough to be able to grok this, but I don’t.

I have a page located at http://actonart.com/offclass/descriptions/. It’s a listing of class descriptions and each one of them needs an anchor so visitors can jump to it from other parts of the site…usually from OTHER pages. I’ve been using JW’s anchor stack and it clearly does work, but not all the time. If there are less than 10 anchors on a page it seems ok. Add any over 10 however and all those don’t work. They jump to random parts of the page, usually no where near any anchor. I know the anchors and links are set up correctly because some of them always work! But I cannot get them all to work.

As an example. Visit this page http://actonart.com/offclass/classes/ . Scroll to the boxes that list the classes by name. Click any of the blue “more info” buttons at the bottom. The top nine of them work, but everything below doesn’t. What could possibly cause this kind of failure?

I appreciate any help you can offer.


(Doug Bennett) #2

Looks like you are using an older version of the JW anchor stack. v1.0 is listed. He has a fix out that should resolve your issue.


(John Goodnough) #3

Ok. So it’s no longer called Anchor? Now it’s just Link? No wonder I wasn’t aware of the change. Thanks for the info. I hope it’s a fix.


(John Goodnough) #4

Ok, this is definitely not the right thing. The Link stack doesn’t have any way to set an anchor. There is no Anchor stack on JW’s web site that I can find now.


(Doug Bennett) #5

There are two stacks with JW’s link and anchor stacks. One is called “link” this would be used to add a link to any stack you want. The second is called “link anchor.” This one adds the ID to a location on the page you want to jump to. That is the one you are having problems with.

I think the current version number on these is 2.3.
Just download the latest versions from Joe’s site.

Browsers have changed, so the old way to " anchor" points no longer work, that is why there is an update.


(John Goodnough) #6

Yup. I just did download Link Anchor off JW’s web site. When the file appears on my desktop it’s named “Link.dmg” It decompresses as the Link stack ONLY.


(Doug Bennett) #7

That would be a question for JW support @zeebe @joeworkman. I have them so updating via stacks works fine for me.

You could also use rwextras anchor point:
https://rwextras.com/anchorpoint/


(Joe Workman) #8

Looks like an older version is getting downloaded. That should auto-update to the latest version though. Its still just one stack. The Anchor stack is embedded inside that Link.stack file.


(John Goodnough) #9

I’ve tried to use Anchorpoint but it won’t install for me. I’ve been assuming it’s no longer functional in RW7 because every time I try to install it simply goes directly into the trash. And I also have the old version of Link Anchor running in Stacks 3 but it never updates, so I guess it’s too old for that functionality. I will contact JW support.


(Joe Workman) #10

Here is a download to the latest version. http://jwurl.net/2vpN3Hg


(John Goodnough) #11

I’m downloading directly off your site so I’m not sure what else to do. The file decompresses without any problem but there’s only the one stack. I keep looking around to see if it’s hidden underneath another icon (unlikely) but it’s just Link that appears in RW. I’ve tried using the installer and dragging the file directly into RW but it makes no difference.


(John Goodnough) #12

Ok. I tried that and it’s the same. Just the Link stack. No Anchor stack to be seen.
I’ll do some troubleshooting elsewhere to be sure I don’t have some as of yet unseen problem with a hard drive etc. This is too weird to be “normal”. Thanks for your help.


(Doug Bennett) #13

Do a search for anchor you should get something like this:
2017-08-02_13-08-17

Make sure you have selected the"all" stacks.

Anchor point works fine in RW7 so don’t know what is going on.


(Will Woodgate) #14

You assume wrong. AnchorPoint works perfectly with RW7. The minimum system requirements for this stack is RW6 and Stacks 3. Hundreds of people are using AnchorPoint in RW7 without any difficulties. There must be something very messed up on your computer if you are using Stacks 3 and you cannot get these stacks to install or display.


(John Goodnough) #15

I’ve just run Disk first aid twice and it clears my drive as fine. Zero problems.
I reinstalled Rapidweaver from a new download just to eliminate that as a possible.

I’m using the Themeflood Photogenic theme and fairly well known reliable stacks that I wouldn’t suspect of any interactions.

Is there any reason to think this might be wifi related? I’m working in a place with flaky wifi that sort of comes and goes periodically. It something were to glitch during a download I simply wouldn’t get it right? Or it would be a corrupt download that wouldn’t expand.


(Robert Ziebol 🖖🏼) #16

Did you do what @teefers suggested and search for Anchor?!? Do that and take a screenshot.


(John Goodnough) #17

This is what I get when I search on Anchor


(Robert Ziebol 🖖🏼) #18

Have you checked for updates???


(Robert Ziebol 🖖🏼) #19

Try this version:
http://d.pr/f/n7YLeD
Uncompress that file and drag and drop it onto the RapidWeaver icon in the dock.


(John Goodnough) #20

Ok! That worked! I’m not sure what the difference was but I now have Anchor showing up in Rapidweaver. Thank you so much for that link.

Let me say thank you to all who contributed to that dialog.

I’m not sure what happened, but sometimes it doesn’t matter how you got there, as long as you do get there!