I really need your help. AD won't show up on website


(SMMNModeling) #1

Okay guys I really need your help. I tried everything but my ad won’t show up on my website.

It is a ad-widget as a javascript through “earnify” and I have tried to place it into the setting panel and directly on the website in the Inspector. It won’t show up on preview and also not once I publish the website on my server.

Maybe you guys can help me out it would mean a lot.

Thank you

SMMN Team


(Stuart) #2

Without a link to see the problem? Impossible to help…


(SMMNModeling) #3

My apology here is a picture


(SMMNModeling) #4

That’s how I did it.


(SMMNModeling) #5


(SMMNModeling) #6


(Stuart) #7

A link to the page where you have added this code would be most helpful. Screenshots get you so far, but seeing the page is much better…


(SMMNModeling) #8

Website: http://socialmediamodeling.net


(Stuart) #9

So, I integrated this widget on a test site with no errors showing in the integration - but there were no ads sent. The call to the service was definitely okay though as I see the 200/OK and a simple payload returned,

Put the javascript in the page or global code container. Do not use tags in these areas as RW will deal with that for you. Use this code:-

(function() {
    var a = document.createElement("script");
    var b = document.getElementsByTagName("script")[0];
    a.async = 1;
    a.src = "http://cdn.earnify.com/widget.min.js";
    b.parentNode.insertBefore(a, b);
})();

Then use the html:

<div class="earnify-widget" data-widget-id="6095"></div>

Where you would like the widget to show up (pretty much as you have done, already.

The errors on your page were caused by:
– The script tags
– Bad URL in the JS. My version fixes that problem and definitely hits the script you seem to need.

These errors do not appear on my page when implemented the way I describe here. You HAVE to fix those errors (as described here) as your page is absolutely NOT calling out to the service.

Furthermore, I can see that when the page loads (and the 200/OK is returned) the div for the widget gets a data value of ‘loaded’, so its all hooked up (as far as I can see).

Give that a try… see if you get any ads (maybe the calls for the content are constrained to coming from your URL?).

My test page is here:
http://technodope.co.uk/
But that won’t be up like that for long as I don’t want to contest with your widget id. But as you will see there are no errors… just no ads…


(SMMNModeling) #10

Thanks a lot for your help Stuart that means a lot. So if I understood if right? Even tho you fixed the errors you still couldn’t see any ads?

I will for sure fix it the way you told me to, so the errors go away but why aren’t ads showing? OR were you able to see ads? Hmm

Thanks a lot SMMN Team


(Stuart) #11

Thats correct. On my test page there are no errors and I can validate that the scripts are loading and seemingly executing correctly - but still no ads. Therefore something is not quite right somewhere, but the starting point for further investigation should generally be having a ‘clean’ error free page.

Were there any additional integration instructions provided by the service?


(SMMNModeling) #12

Those were all the instructions provided I might have to talk to the support if even you couldn’t get ads to show. Thanks a lot for your support, do you know what else it could be? I will keep you for sure updated what the support will tell me.

Merry Christmas :slight_smile:


(Stuart) #13

Okay. Do clear those errors and try again from your domain before contacting support though as it might be the case that the widget id you are calling for is specific to requests originating from your URL and may not be processed properly coming from mine…


(SMMNModeling) #14

Okay I tried your code and it still doesn’t show ads… I really don’t know what to do or what am I doing wrong…

The support said:

Ensure you have copied your widget code into the correct area on your site. We unfortunately don’t offer external support, so you may have to contact your web developer if you cannot implement the widget(s) yourself.


(SMMNModeling) #15

Wow yeeeees it works. I couldn’t see it in preview but I just updated the page on the server and I can see them with your code.

Thank you soo much Merry Christmas and happy holidays.

You are awesome :slight_smile: