Joe Workman Google Maps Stack Not Showing My Location When Activating Content: Location Markers


(Steve Peterson) #1

Only works when I use “Centered Map” selection. Otherwise is previews as SanFrancisco, CA. I have turned off Google Maps Caching. Can someone tell me what’s up?

With location markers turned off:

With location markers turned on:


(Robert Ziebol 🖖🏼) #2

Is this in edit mode, preview mode or on a published page?

Have you read any of the docs at our docs site?


(Steve Peterson) #3

Published page. I expect, based on the way I understand the software to work, that it will show the SF map in edit mode and would also show it in preview if I had “Use Map Image Caching” checked. I read the above referenced documentation before I posted the question and unless I’m missing something, don’t see what I’m doing wrong.


(Robert Ziebol 🖖🏼) #4

Since it is published, do you have a URL for us to look at?


(Steve Peterson) #5

Hey there. Allow me to clarify. The incorrect map is not published on my site since I:

  1. Don’t want a map of San Francisco incorrectly published on my site.
  2. Definitely don’t want crawlers to start caching this information.

The screen shots in the original message in this post were in Preview mode in RapidWeaver. Here is a screen shot of my current settings. Can see that I have Centered Map selected because both Location Markers and Paths selections cause the issue to occur. I have further tested this by selecting Location Markers and briefly publishing to my site to confirm that a map of San Francisco appears on my site, which it did. I then changed the setting back to Centered Map and republished to at the very least make my google map accurate.

The url where the map currently is can be found at http://www.petersonsocialmedia.com/Contact/


(Steve Peterson) #6

We seem to have gone dark on this thread. Still not working as advertised. How can I fix it or get my money back for this stack that’s not doing what I need it to do?


(Robert Ziebol 🖖🏼) #7

Sorry, I will get back to you later today.


(Steve Peterson) #8

Thanks zeebe. It feels like something minor and silly but for the life of me I can’t figure it out.


(Steve Peterson) #9

Figure anything out?


(Robert Ziebol 🖖🏼) #10

Not sure if you would say I figured it out, but I have not issue with it working in preview for me. You have to be sure to enter the location in the marker below the map in Edit Mode. See my video here to show you it works.
Video Link


(Steve Peterson) #11

Super video zeebe. A pretty dumb mistake on my part. Didn’t know the frames under the map were editable. I thought the address in the map center drove the location coordinates. It’s fixed. Thank you!