Kalendar Update - SOLVED

The Kalendar stack has a new update 2.1.2 which is supposed to fix “links” after updating within Rapidweaver it made the two websites I use this stack for useless. So you may want to wait to update.

OS: 10.13.6
RW: 8.5.1
Stacks: 4.04
Theme: Mint them Elixir Graphics

Example here: https://michiganncrs.org/Events%20Calendar/events_calendar.html


I don’t know if it is relevant but I see that there are a couple of problems connecting to links: https://michiganncrs.org/Events%20Calendar/files/ical.min.js.map and https://michiganncrs.org/rw_common/themes/Mint/bootstrap.css.map

Since the second one is related to the Mint theme, it can’t be caused by Kalendar.

Interesting, its was working fine in that theme until it was updated to 2.1.2.

The other theme it’s not working in is Michael David Design Affinity 1.1 (did not publish the update)

Same thing happened after the update, they were both doing fine.

One of my previous requests was that links were not working within the stack, there was never any response.

Thanks for letting us know - I can confirm that the stack is broken after the update (I use foundation (not 6)), and the preview already shows the page rendering broken having done nothing else but the upgrade. (@weavium)
If I have time later, I will try to provide a test page)

Hi all,

Thanks for letting us know. I hadn’t changed anything major, not sure what would have happened, but I will get on this right away.

Hi again,

There must have been some odd compiling error right as I compressed the file before updating. I believe i’ve fixed the issue and pushed out another update (Version 2.1.3) that should solve everything. Please update and let me know.

Thank you and sorry for the hassle~

1 Like

Just updated to the new release - as far as I can tell, the problem is fixed. Thank you for your quick response, great service - Cheers.

Now back to working for me as well, Thank you.

However I had inquired on this before; when adding a link to an external website it sets up properly in RapidWeaver but when published there is no link.

Not sure that I understand your request properly, but when I have “Markdown Event Descriptions” enabled in the ‘General’ settings, then I can add a link to an external website using markdown syntax in the event descriptions.

The links work both in RW review mode, as well as from the uploaded website. I tried it with both an internal calendar event, and an external calendar event - both worked.

Ahhh! Thanks for that, was not using Markdown, now working.

Sincerely appreciate you taking the time to help.



Rich, might want to change the title of this thread, you should be able to click on it and edit it since you are the OP. That way people don’t get scared of Kalendar just off of this thread title.

Thanks, somebody beat me to it.


I don’t see any update past version 2.1. I have had this before with other stacks and always wondered why.

I’m using RW8 and just updated it within the library.
See screenshot showing 2.1.3


I downgraded to version 2.03 that was in my downloads and it then upgraded to the latest version, weird.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.