Language markup


Does anyone know how to fix a language markup problem through RapidWeaver?

I get the following error messages:
“One or more of the specified languages are not ISO standard (en, en-us, de, etc.)”
“The language is not specified in the HTML markup.”

I have the code but am not sure where to add it.

Responses would be appreciated.

Best, Natasha

PS: the URL for this is

Looks like you are using the Kiki theme.

Are you using RapidWeaver 8?

The default HTML5 Language Attribute should be on the html tag.

RapidWeaver should apply this automatically based on the Site Language in general settings. I think they added this feature with RW8.

I just did a quick test with the Kiki theme and it works for me:

Yes, thanks for the prompt response. I am not using RW8 but RW7. I have read that an upgrade to RW8 might mean the complete loss of the projects created with earlier versions and am therefore not upgrading. There is no possibility to add this in the settings. Where else could this be added as a code snippet?

RapidWeaver generates the HTML tag. There really is no way to add it as a code snippet as it is an attribute you are trying to add to a generated html tag.

You could go and manually edit the html with a plain text editor, but that would get really messy. Every time you changed a page, you would have to reapply the edits for every page.

The update process from RW7 to RW8 for most folks was a very smooth upgrade. Of course, you want to make sure you have a good backup before any upgrade. You can actually run both RW7 and RW8 on the same machine.

RapidWeaver 8 will open up an RW7 project file and make a “new” RW8 project file for you. The original RW7 project file should be “untouched”, and you could open it up in RW7 if needed.

1 Like

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.