Main Window Side Bar Not Appearing


(Richard W. Jones) #1

I upgraded to the latest RapidWeaver release today. I cannot seem to make the Sidebar that lists pages next to the main window. Tried all sorts of View selections without success. Can anyone help?


(Robert Ziebol 🖖🏼) #2

I would normally say Search is your friend, but this would be a hard one to search for if you do not know what you are looking for, follow this:

Simplified instructions that usually do the trick:

Open Terminal.app
Copy/paste:
defaults delete com.realmacsoftware.rapidweaver6 “NSSplitView Subview Frames Main Document SplitView”

Press Enter
Restart RapidWeaver.

@nikf I think this might need to go in the FAQs which should also be a pinned thread on the top of the forums. Like “Read the FAQs before posting” or something similar.


(Mark Sealey) #3

Richard,

Could it be that somehow it’s accidentally been collapsed left?

You can achieve that on purpose by later hovering over the vertical line that separates the sidebar (Source List) you’ve now lost and the main content pane.

The cursor turns from a pointer into a small cross where the vertical line can grab the divider, and the horizontal line has arrows pointing left and right

Slide it to the left or right to see the sidebar shrink and expand.

You should find that - even when the sidebar is not visible - placing the pointer on the very far left edge of the RW window will also turn it into a sliding tool. Drag it rightwards and the sidebar should reappear.

The same can be achieved from the View menu: Show or Hide Source List; Option + Cmnd + L

Good luck!


(Richard W. Jones) #4

Thank you. Your advice helped. A second issue is that a Stacks 3 list was hiding the Source List. Finally got it handled, though, so thanks again.


(Doug Stansfield) #5

I followed Zeebe’s advice , and it worked. Thank you! I have had this problem multiple times and usually something seems to fix it…but this time was stuck and so found this post and fixed it. Isn’t this a bug that needs to be fixed?


(Brian LaPan) #6

If you can recreate the steps to cause that bug to happen, please send them to support@realmacsoftware.com. We’d love to smash it, it’s just that we haven’t experienced it ourselves yet.


(Keith) #7

Hello, I have the same problem… have tried all suggested steps to resolve it…but no luck