Lost website theme sidebar and header


(webdesign44) #1

My header and sidebar have vanished from the work area of Rapidweaver.
I must have changed the work area viewing options, but for the life of me I can’t find the setting to get these two elements back. All I can see is the main body of the theme but no header or sidebar navigator.

Any help much appreciated.


(Rob D) #2

Yeah, that happens sometimes to me too, especially when I use partials. The stacks that seem to be missing in Edit mode are still there in Preview mode, but they are “covered” by partials that I add after the “missing” stack. I have no idea what causes this phenomenon.

I make a copy of the affected page (just in case) and then I save the project. Sometimes saving does not help, other times, the “missing” stack reappears.

I thought I was the only one with this issue, therefore I did not complain publicly.


(webdesign44) #3

All of my pages are effected. I’ve tried saving and re-opening.
It looks like a setting to me to hide header and sidebar, which in my opinion is useless if you need to edit something in the sidebar.
So frustrating, I might even have to start from scratch.


(webdesign44) #4

I just tried a new project and then tried different themes, but still no luck.
might have to re-install RapidWeaver.
is anyone aware of options to change the workspace view?


(scott williams) #5

just to be sure, did you quit RW and relaunch?


(James Dwyer) #6

I had a similar problem after installing X-ray, I think — assuming I have understood your issue… Robb at Joe Workman’s support desk offered this solution:

Robert Ziebol, May 5, 15:29:
This is just unfortunate timing as this is a known issue with RapidWeaver 6. Try holding command and pushing the 2 key. If that does not work, try opening the terminal and pasting this in it

defaults delete com.realmacsoftware.rapidweaver6 “NSSplitView Subview Frames Main Document SplitView”

One of those should get it back to normal.

This bug is well documented on the forums and I am sure not all of those people who have had this issue are running x-ray, so I doubt it is the stack.

Robb
The Support Jedi


(webdesign44) #7

Yeah swilliam I did quit and relaunch.
Jim_D - I thought you have found the answer to my problem, but alas - Command 2 didn’t work.
Terminal keeps throwing up "Domain (com.realmacsoftware.rapidweaver) not found.
Defaults have not been changed.

Thanks
Mark


(webdesign44) #8

Command 2 - “Pages & Resources” (under Menu/View) doesn’t seem to do anything, not even a flicker.

I’ll give a little history on when it all went wrong. I was looking for a way to enter a HTML script line into RapidWeaver but couldn’t find an answer even in google. I then wondered what the difference was between the Info button and the Inspector button thinking I might find an answer there.
If I recall I clicked the Info button three times and the header and side bar vanished. I can only view the main body of the web page inside Edit. The site previews just fine.


(James Dwyer) #9

It may not be the same issue Robb was addressing for me. Sorry.


(webdesign44) #10

Thanks Jim
I’ve contacted the theme author to see if they can help.
I’ll update here incase it might help anyone else.