Native rapidweaver sitemap and the loghound add-on sitemap

Hello,

This is the issue I’m having:

I have 3 sitemaps uploaded at the root of my site:

sitemap.xml

sitemap_frenchlinensonline.xml

sitemap_index.xml

Each is a different code.

#2 (sitemap_frenchlinensonline.xml) is produced by the sitemap add-on (loghount sitemap). It has all of pages files as set up by me inside of that sitemap add-on.

*My guess is that the other 2 (#1 & #3) are produced by Rapidweaver. Both files get uploaded to the server if the option “Generate Search Engine Sitemap” (the native Rapidweaver sitemap) is turned on/ or off - same result, I tried both ways (upload was done after I deleted all of those sitemaps files from the server. *

The problem is that #1 (sitemap.xml) is a short file, it only shows certain pages of my website - the top horizontal menu (pages that are: contact, about us, policies), but not the left side vertical menu where all the products are.

#3 file (sitemap_index.xml) is this:

`* <sitemapindex xmlns="http://www.sitemaps.org/schemas/sitemap/0.9”>*`

`*<sitemap>*`

*<loc>[https://www.frenchlinensonline.com/sitemap_frenchlinensonline.xml</loc>](https://www.frenchlinensonline.com/sitemap_frenchlinensonline.xml%3C/loc%3E)*

*<lastmod>2020-01-06</lastmod>*

*</sitemap>*

*</sitemapindex>*

My question is:

Is it OK to have all 3 uploaded? (For google search - I did have the issue Google “not indexing” all my pages that are not the “top menu”), I submitted all pages one by one manually on google console.

I suppose that since the file #2 (sitemap_frenchlinensonline.xml) is the one that fully shows all of my website, it’s the one that I want Google to look at?

So my thinking was that if I delete the other from the server, turn of the native Rapidweaver sitemap, upload again, I will end up having only #2 file on the server. But as I mentioned above, it did not work, all 3 above files are back again on the server after the re-upload.

Please advise

Thank you in advance,

Natasha Touchinski

my site is frenchlinensonline.com

There have been a lot of changes in recent versions that affect sitemap generation, both by the plugin and the RW native sitemap.

So the first question is what version of things do you have:

  • RapidWeaver version
  • SiteMap+ version
  • macOS version

I’m not 100% certain what will happen if you have superfluous sitemap xml files on the server. I suspect they will be ignored, but I wouldn’t risk it myself.

If you are using RW 8 and SiteMap+ v3.2.1 then disabling the native sitemap and enabling the SiteMap+ sitemap should generate and upload only a single file.

Although there are some experts that like to interesting names for their sitemap, I recommend just having a single sitemap.xml file, named just like that. This keeps things simple and predictable.

If you need to download the new version of SiteMap+ it is available on the YourHead website: http://yourhead.com/sitemap/

When YourHead took over SiteMap for LogHound we released the version 3.x upgrade to clean up the user interface, improve RapidWeaver 8 compatibility, and fix a number of bugs.

SiteMap+ version 3 is a FREE update

1 Like

Hello Isaiah,

Mac OS 10.13.6

RW 8.4.1

Stacks 4

Pluskit 4

Sitemap Plus

All the RW & add-ons are the latest versions, just reinstalled everything new.

So far I’m not able to disable the native RW sitemap. The file it makes still gets uploaded to the server with the sitemap option unchecked. Tried it more that once (and deleted those files from the server before the re-upload). They just go back on again.

Also, how do I change the file name for the LogHound sitemap (as per your suggestion to name it just “sitemap”)? The add-on is naming that file itself by adding the name of my project file so it becomes sitemap_frenchlinensonline.xml.

What is there that I’m missing?

Thank you in advance,

Natasha Touchinski

You left out which version of SiteMap you’re using. And since that’s sort of the key to this problem, it’s pretty important.

“Latest Version” is unfortunately not really unambiguous for SiteMap.

  • The “latest version” available from LogHound is v2.9.13
  • The “latest version” available from YourHead is v3.2.1
  • The latest beta version is v3.2.0 beta 1

If you are using anything other than v3.2.1 then it’s very likely that the solution is just to download v3.2.1 and install it.

There’s also the real possibility that you have more than one version installed (see below).

If you’ve recently manually downloaded a version v3.2.1 from http://yourhead.com/sitemap , but the version listed in the RapidWeaver addons window is not v3.2.1 then you’ll need to open the RapidWeaver addons folder and manually remove the old version(s) and reinstall the new one.

And then in the project settings:

This is no longer a feature of sitemap (for exactly this reason). This makes me think that this problem is caused by an old version – either that is still installed – or created the SiteMap page in this project and some of the old features (like name-changing) are still active on the page.

I’d recommend first verifying that you’re using v3.2.1. If you’re not, fix that first and see if the problem continue. I suspect that will improve things.

However if problems persist I’d recommend deleting the SiteMap page and creating a fresh new SiteMap page.

** SiteMap has, over its history, had a variety of capitalizations slight variations in the file name of the plugin and the RapidWeaver plugin updater hasn’t always been perfect when updating after a file name change like this. This has lead to the circumstance where some users have multiple versions installed – but only one version (macOS chooses one – but it’s undefined which one) will load.

It is v3.2.1

Screen Shot 2020-01-07 at 6.13.46 PM.png

Do I delete the page where the ad -on is, and create it again?

It is v3.2.1

Do I delete the page where the ad -on is, and create it again?

I’d recommend ensuring that you only have a single version installed.
I’d recommend deleting the existing SiteMap page and creating a new one.

If that doesn’t solve the problem, then there is something much more insidious going on. I would then try a new sitemap page in a brand new project file (just as a test). If that works and the old project is still causing problems, then you should contact YourHead support and send your file and addons folder:

Thank you,

I will try that, let you know what happens.

Natasha

Yes, deleting the sitemap page, and creating it back again did help! Thank you a lot!
Sitemap Plus named it correctly (sitemap.xml), and I no longer have multiple sitemaps on the server!!!

Natasha

Yeah! I’m very glad to hear it. That was indeed a strange problem. If that didn’t fix it I would have been truly out of ideas.

Isaiah