Navigation menu links not working

Actually, the menu links worked fine for weeks, needed to reinstall macOS Mojave.

I restored the files from TimeMachine, but I can no longer use the links on the site - in preview mode or after publishing to my host.

I click the page name in the menu but nothing happens.

FYI I am using the Mirage theme.

I have tried:

  1. reinstalling RW 7 (I purchased version 8, but I want to fix my site before updating).

  2. Unclicking that Tidy-whatever box in General Settings and completely republished all files.

  3. Looking at all my page settings.

Now, I am lost and don’t know how to proceed.

Can it possibly be related to Application Support in macOS Mojave? I restored those files from TimeMachine, too, but who knows.

I would appreciate your help, if you have some suggestions.


I would suggest first posting a link to your site so the helpful folks here can see what’s going on with it, and hopefully find the cause and solution. Really not possible to help troubleshoot otherwise.


What exactly did you “unclick” and why?
If you unchecked use tidy links then that might have caused the problem.
As David (@thang) said a URL would be helpful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.