Need help - page suddenly renders as gibberish


(Patrick Murphy) #1

I have a RW site that’s worked fine for years. Today however, when I preview or publish a page, the page renders as gibberish.

Here is a typical (good) page, before this problem:

Here is a similar page, as it appears today:

If you scroll down eventually there is content but it is all mixed up. If you want to see for yourself, the page is, unfortunately, live at http://www.ilda.com/entries2018.php.

The gibberish appears both in RW’s Preview as well as if I publish the page to the web. It appears in any format – mobile, iPad, full width.

I’m using RW 7.5.5. I rebooted my Mac (High Sierra 10.13.3) but the problem remains.

It is not a problem in the .RW file. I tried an older .RW version which had worked fine, but when Previewing or Publishing today RW produces gibberish.

The only change since last time everything worked was that I updated my various stacks. I have 66 stacks and so I am hoping I don’t have to go in and reinstall them all. I did not change the theme (Foundation).

Any clues or suggestions?


(scott williams) #2

There is an error on the page having to do with loading the CSS and a reference to google fonts. Did you make any changes to fonts or add any CSS / JS or other code yourself?

If not, try a republish all files, your CSS is not being loadeed


(Patrick Murphy) #3

Thanks, I looked into this but I don’t think loading CSS or google fonts is the cause. (And I am not seeing this error in Safari 11.0.3.)

The project does not have any sitewide CSS or JS code. I have the following JS code on each page, which has remained the same for many months (no recent editing):

42%20PM
There is no CSS code on each page.

I tried republishing the entire project to a local folder but all that happened was that every page “went bad” and became gibberish. Here are my settings:

54%20PM

So I still need help. As a reminder, the site is www.ilda.com. Online it is fine except for the page I published earlier today, http://www.ilda.com/entries2018.php which came out as gibberish, with no apparent formatting.

Inside RapidWeaver, when I look at any page of the site with Preview it now looks like similar gibberish. Obviously I haven’t published any of these since I need to fix the problem.

I am thinking something with stacks since updating stacks was the only change I made since things worked a week ago. I have 66 stacks however and don’t want to reinstall every one if I don’t have to (or unless a specific stack can be shown to be the cause.)

Thanks again for any help!


(scott williams) #4

The error is definitely there. Now whether it’s the problem, that’s another question.
ZZ6B6D9A0E

Maybe @isaiah can chime in and help you determine if it’s a Stacks issue since that is the only thing that has changed. What version of Stacks are you running? Any other plug-in’s (pluskit for example)?


(scott williams) #5

One more thought… Is your Foundation Theme up to date?
Answer - No, it’s not. I would update the Theme first it’s possible your Theme and Foundations Stacks are “out of sync”


(Don H) #6

I think Scott is on the right track with the Foundation theme not being up-to-date. It doesn’t look like the page with issues is loading the base foundation css file (foundation.css). Your working pages are.


(Isaiah Carew) #7

i don’t have enough info to make a solid guess at the cause, but i think the other posters guess of it being foundation version related is a reasonable first thing to try. and whatever the case getting your foundation things up to date probably won’t hurt.

so give that a shot first.

also: make sure you have a good time manchineel backup working. it’s great for things like this where things suddenly stop working. you can just back up the history of the file or of your addons folder until things are back to normal and see what exactly changed.


(Patrick Murphy) #8

Thanks to everyone. It does seem to be due to an out-of-date Foundation theme. I’m not 100% sure but so far the problem seems gone with the latest Foundation version. I’m currently republishing everything. If this goes fine then I’m OK and VERY relieved!

(Is there a way to automatically update themes? I noted that I could not right-click on the theme and select “update”. Or do I have to track down each theme and manually download the latest version?)

Isaiah, thanks also for the reminder about Time Machine. I do use Time Machine and also Dropbox. I was going to put back my older RW and stacks folders to try to solve this. But you guys rock and saved me a LOT of time.

Thank you again!


(scott williams) #9

You are welcome,

There is a plug in called waterfall that will alert you to “some”theme updates, you may want to check that out.


(system) #10

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.