Pretty URL's - New .htacces file?


(Adriano ) #1

Hello RapidWeavers,

I’ m setting up pretty URL’s for my blog.
I copied the code that pop-up when I change the settings of the page to pretty URL’s inside RW:

Pretty URL rules to paste into your .htaccess file

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule article/(\S+) /article/?permalink=$1

And I’m ready to paste into my .htaccess file, but the dilemma is: … do I need to create a new .htaccess file, or can I use the same one where there is the code for the “https redirect”?.


(Paul Dennison) #2

Just add it in to your existing one as, so to speak, “there can be only one!” .htaccess file.


(Adriano ) #3

Hey pmjd,

Thanks for your answer.

I did as you suggested and is working! :slight_smile:

So, how many codes can I have in one .htaccess file?
Cheers.


(scott williams) #4

All you need…


(Adriano ) #5

Thanks for the info.

:slight_smile:

Cheers guys


(Adriano ) #6

Although I have copied, pasted and saved the code in the .htaccess file (I have checked on my FTP-Filezilla, and File Manager in Cpanel), when I go inside RW and preview the page or external previewing it, I get the same message:
Below are the rules that you will need to make pretty URLs function. Paste them into a text file named .htaccess at the root of your website.

Pretty URL rules to paste into your .htaccess file RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule article/(\S+) /article/?permalink=$1

That’s weird, it looks like RW is not reading that the change is made, as the pretty URL is definitely working (I checked on the browser).

Does anyone have an idea on how to stop this repetitive message?.


(Adriano ) #7

Sorted :grin: !.

I just had to de-activate the “Show the .htaccess rules” option inside RW.
I didn’t realise it was still on just below the pretty URL’s settings!.

Thanks


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.