Having trouble with "really pretty URL's" and Total Blog


(Garth Poon) #1

Hi everyone,

I’ve set up really pretty URL’s and Total Blog before and it’s worked fine. I’m just having trouble with this new website.

Here’s the website: https://dadthings.ca

These are the instructions I followed: https://docs.joeworkman.net/rapidweaver/stacks/cms/total-cms-blog/really-pretty-urls

Here is the htaccess rule I used:

Pretty URL rules to paste into your .htaccess file

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule https://dadthings.ca/(\S+) https://dadthings.ca/post.php?permalink=$1

I suspect the problem is related to the fact that my blog is on the home page instead of a folder called /blog

Does anybody have any suggestions on how to fix it so the pretty URL works?


(scott williams) #2

make sure it works without pretty urls first
then
set the pretty url option
preview the page in RW
a pop up window will apear and give you the opportunity to send changes to your server - do that
copy the .htaccess code that displays in the window as well and add that to your .htaccess file


(system) #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.