Question concerning TopBar - SOLVED

Since few days my website is modified by using RWML for an english and german version.
Works fine so far.

The select-flag for english or german is in the content area in the moment.
I would like to put it in the menu area.

So i activated the TopBar Extra Zone and selected “Dropzone”.
Put the rwml-stacks in the dropzone, but the result is not as i would expect it or as it is in the foundation.rw6 by Joe Workman.

When selecting a page, the topbar looks like this:

When scrolling down, it changes to:

I want the TopBar Extra Zone to be displayed in the topbar and not under it. And i want the topbar to keep it’s normal size when scrolling.

Any suggestions?

MacBook Pro, OS X El Capitain 10.11.6, RapidWeaver 6.4, Foundation newest available version.

Thanks a lot, Barbara

I have those language stacks, can you show me a screenshot in Edit mode so I can try to understand exactly what you have where??

Yes ofcourse:

In the meantime i put the selection above the menu bar, that looks better than in the content area anyway. But it would be nice to have it sticky as the top bar…

Hi, Barbara,

Do you really need your language-flags to be sticky? Do you realize that once a viewer selects their language, that language is recorded in a cookie and is used throughout the website (so there’s no need for a viewer to click on a flag again)?

I don’t need to, but i would like to :wink:

Try playing with the settings in your Topbar. Adjusting the height will make a difference. Also I removed the title padding for more space.
see here.

Thanks a lot!
One additional question:
Are you using RWML for changing english <—> german?

Yes, go see the link to the site. its german and english using RWML and works well.
If you need more help let me know.

I am playing arround with the adjustings, but the only thing that works for me in the moment, is to set the padding in the custom sizing to 0(zero) and the result looks awful. But at least the size of the top bar remains the same.

I solved the problem, but i don’t know what really was the point.

I tried the following:
I started by putting a RWML Switch Styled stack in the TopBar Drop Zone.
The content oft he Switch Styled Stacks was:
„Sprache wählen:
„Select your language: “.
Both flags are bigger, the width is set to “25”.

I had the described issue.

Next step was using the RWML Switch Image stack. I put the picture in there, the issue remained the same.

Next i took other (smaller) flag pictures in the Switch Image stack. No change.

Then i tried with different sizes in the custom sizing of the TopBar. And then for the very first time, the TopBar had the right size, remained in this size when scrolling and the flag was positioned in the TopBar itself. I just had to set the padding in the custom sizing to 0 (Zero). But the result looked awful, no option to use these settings.

All the time i was in contact with Robb from Joe Workman. Thanks a lot!

Then i got in contact with Tsooj Media, as Robb has realized, that Anugyan (who is using TopBar Extra Zone with RWML as well and it works) was using RWML 2.0 but me i had 1.1.2.
Joost from Tsooj was so kind to give me the opportunity to try the beta of RWML 2.0.
So i tried this one.

With the Switch Image Stack the issue remained the same.

But with the Switch Styled Stack i got it working!
As i am using smaller flags now, the input in the stack is:
„Sprache: “.
No width declaration, size is original.

I have two drop zones in the TopBar, i have a RWML Content stack in every drop zone and the RWML Switch Styled Stack in every RWML Content stack.

Maybe it would have worked this way with RWML Switch Styled Stack 1.1.2 too and the point was, that i had the width declared when first using it.
But with the Switch Image Stack it does not work the same, even with RWML 2.0.

In the end, i got it working now and i am really happy about it!

Thanks to all involved.

1 Like