Quicktime plugin missing when trying to play movies


(Bruce Kieffer) #1

I’ve been evaluating different themes to purchase. I’ve noticed that all are having trouble with missing movie playing plugins. I’ve tested on Mac Safari and Firefox. I think this is a problem or limitation with OSX 10.11. How are people working around this on their sites?


(Robert Ziebol 🖖🏼) #2

I think this is because you are playing .mov files, which is a VERY out dated format and most browsers do not allow for this anymore. I would suggest converting your movies to .mp4, you can get a great free video converter here:
http://mirovideoconverter.com

This will also convert the files to webm and ogv files so other browsers who do not support mp4 can play them, I would suggest using a player that supports all types of files like Joe’s HTML5 Video stack


(Bruce Kieffer) #3

I believe you @zeebe. Please look at the movies on this site’s page.
http://michaeldaviddesign.com/themes/halogen/movies/index.html
Can you tell if they are .mov files?


(Robert Ziebol 🖖🏼) #4

My guess would be yes, they are .mov files, it is probably using the old Movie Plugin that came in RapidWeaver 5 and lower. I can not tell for sure, as I can not inspect the page that comes up and says I am missing the QuickTime plugin.


(Nik Fletcher) #5

Not sure that’s the problem here:

http://michaeldaviddesign.com/themes/halogen/movies/files/page3-movie-1.MOV is the source file and it plays fine. Looking into why this isn’t working - however, I should note that we’ve retired the Movie Album plugin…

—N


#6

I’m now seeing the same problem, running El Capitan when I try to watch a Quicktime movie its says the plug-in is missing.


#7

There are two locations that could be causing this HD/Library/Internet Plug-Ins or /user/Library/Internet Plug-Ins

Look for a folder called Disabled Plug-Ins, if Quicktime is in there then drag it out into the Internet Plug-Ins folder, you may need Administrator access, make sure that after it has moved that the version in the Disabled Plug-Ins folder is deleted. Check both user/Library and HD/library.

Restart Safari and see if this fixes it


#8

I don’t understand why Apple does not offer the ability to record in .mp4 format on iPad and iPhone Cameras. Both devices can play .mp4 movies (H264 codec) so I it makes no sense that they restrict their cameras in this manner. I record over a thousand movies per year for my website and they are all in .mov format for this reason, I think its time of Apple to let go of .mov


(Bruce Kieffer) #9

I found the disabled Quicktime Plug-in, moved it to be enabled, .movs play now.