Rapidmaps4 API error

since google changed how api are used sometime in I think 2018 my map fails to display and I get:
Oops! Something went wrong.

This page didn’t load Google Maps correctly. See the JavaScript console for technical details.

I have spent hours trying to fix this. I followed the developers instructions, I generated and api placed in the plugin republished the site and still no joy.
I created a google account for my google project then regenerated an map api and again no joy.
What am I missing: the api is enabled and it api for the google maps. When I look at the java console I still get this message: Java console gives me this error: Google Maps JavaScript API error: ApiNotActivatedMapError
Foreground developed Rapid Maps but the support page not helpin

The error is self explanatory in the Google Maps documentation you have linked.

The Maps JavaScript API is not activated on your API project. You may need to enable the Maps JavaScript API under APIs in the Google Cloud Platform Console.

I’m not trying to be a pain but this is the code in RW 8 viewing my page in Preview mode:

div style=“text-align: center; color: red; font-weight: bold; background-color: rgba(255,0,0,.2);”>

But have I the java script API and I have and active account with google: the api I place in the plugin is (AIzaSyBOtBTpPdzyEPWH0qxlSGmE8kLvnIlIoJU)

Obviously without the (). I have placed that API number in the Maps API key box and save my project but when I try to view it in preview there is no map and the HTML is as above.

Have you seen this before or is this a RW 8 issue?

Do need to delete Rapid Maps and then add the plugin back into my project?

I don’t have rapidmaps but I know the same issue happened with DooBox Maps2. you had to add the localhost or the preview IP address to Googles list:

Please contact us at help@4gnd.com attaching a link to your published RapidMaps page.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.