๐Ÿž RapidWeaver 7.2 Beta 7 (18473b) ๐Ÿž


(Dan) #1

Hey Weavers,

RapidWeaver 7.2 Beta 7 (18473b) is now available with the following fixes:
Lots of long standing issues have been fixed in this beta. Almost time for the official release of 7.2 I think!

  • Fixed an issue where RapidWeaver would re-upload all resources on every publish
  • Fixed another issue relating to the banner path macro.
  • Fixed an issue where editing the โ€œprefixโ€ area in the sidebar would cause a crash
  • Fixed an issue where RW would upload all blog pages if the blog was the index page
  • Fixed an issue where the blog categories would sometimes not be exported

This is a beta release of RapidWeaver, do not install this unless you are comfortable with using pre-release software. Please backup all of your project before using.

Download RapidWeaver 7.2 Beta 7 (18473b):
https://dl.devmate.com/com.realmacsoftware.rapidweaver/18473b/1481822343/RapidWeaver-18473b.zip

Check for updates if youโ€™re already running a beta build or directly download it from the link above.

Happy Weaving!

Cheers
Dan


(Dan) #2

(Andrea Vitali) #3

@dan: still RW 7.2b7 freezes when I open a 7.0.4 project and after migration and some smaller changes I hit save or save as.
If the little one will allow me some hours of work tomorrow Iโ€™ll try to check if the same issue persists with Sierraโ€ฆ Iโ€™ll install on a cloned disk.

sorry for the bad newsโ€ฆ Iโ€™ll send You the project files on dropbox


(Stuart) #4

This version has fixed all the issues I had with my messed up theme drawer (gaps between themes, themes disappearing and sometimes themes flickering). All good nowโ€ฆ in fact the theme drawer has never looked better.


(Dan) #5

Hereโ€™s the download link to the final version of 7.2 - https://dl.devmate.com/com.realmacsoftware.rapidweaver/18482/1481909903/RapidWeaver-18482.zip

Weโ€™ll be officially releasing this next week.

Donโ€™t panic if your bug or issue didnโ€™t get fixed in this version, weโ€™re already hard at work on RW 7.2.1 :slight_smile:

Happy Weaving!


(Gary Wann) #6

v7.2 installed and working OK with my RW project thanks.


(Mark) #7

Working very well now.
Previewing, publishing both work with no errors.
Thanks!


(Mark) #8

Just noticed a small issue that occurs randomly:

When preview mode: When editing a stacks setting via the inspector window, RW7 will continuously display โ€œGenerating Previewโ€, over and over again without updating the preview. It seems stuck in a loop. This seems to occur more frequently when editing settings in markdown stack.

This is easily overcome by switching back to edit mode then back to preview mode again. I donโ€™t normally edit a stackโ€™s settings on the fly in preview mode. (I usually work in edit mode).


(Paul Russam) #9

If you are editing a value thatโ€™s in a setting with up and down arrows then clicking the/an arrow will cause RW to refresh the preview. If you click it quickly 10 times then itโ€™ll attempt to preview the page on each change of the value, this will produce the result you are describing.
If you know you want to add 10 (or whatever) to a value then type the new value and hit return.


(Dan) #10