🐞 RapidWeaver 7.0.3 Beta Now Available


(Dan) #1

Bonjour Weavers!

We’ve just released a beta of 7.0.3, you can take part in the beta by enabling the option in the RapidWeaver preferences window…

Here’s what’s new:

  • Deleting themes from the Theme Browser now works
  • Site and Page meta tag output is no longer duplicated
  • Duplicating page no longer gives issues on Preview
  • Directory listing now works when browsing via SFTP
  • Server Path is now cleared when changing publishing type to local folder
  • Duplicating themes now duplicates theme styles also!
  • Fixed a whole bunch of issues with FTPS
  • Fixed a publishing issue relating to bookmarks
  • Blog plugin now generates correctly URL’s for podcasts (sorry this took so long to ship).
  • Cache busting no longer breaks when using protocol-less URLs
  • Fixed an issue with lists in the style text plugin.

We hope to have an official 7.0.3 release out later the week. We’re also working on 7.1 at the same time, this has some bigger, more exciting things in it but more on that next month :wink:

Happy Weaving!

Cheers,
Dan


(David W McQuarrie) #2

Since installing 7.0.3 (17828b) When I try to preview my Welcome page I get this

error


(Mathew Mitchell) #3

7.0.3 seems to be working fine for me.

The bug I was experiencing was the “export bug” wherein pages where exported but the process was “weird” (i.e. exported, then published) and left all the pages marked as changed. Hopefully this will be fixed for 7.0.4 or 7.1. But I’m hopeful that now some key bugs are sorted, that some others can get solved!


(Dan) #4

@davidwm Can you send a copy of your project along with the theme to support@realmacsoftware.com and we’ll look into it.

Can you re-create the issue with a new project and using a built-in theme?

Cheers,
Dan


(Frank Land) #5

Same here!

Navigation Theme


(Michael M.) #6

Is it still necessary (or recommended) to define a ReWrite Rule in the .htaccess for caching or not…?

What are a “protocol-less URLs”…?


(Doobox Software) #7

@apfelpuree A protocol-less or protocol-relative url’s are a url’s that begin :

//

As opposed to:

http://

Or:

https://

//www.example.com/style.css, that is a protocol-relative URL; it uses the same protocol as what the browser is already using to request the referring page. For example, if the browser had requested a page with https://www.example.com, then that URL will be requested over HTTPS and not HTTP.


(Chris) #8

Just tried to use the new Alpha Colour option in a theme but it didn’t work. Do we also have to make changes to the theme color section for the individual colors (they had to be in hex before). Tried it with rgba() but this will make RW hang.


(Dan) #9

RapidWeaver 7.0.3 beta 2 is out, it fixes up a few more things (including the exception while exporting error).

@cric We’re still looking into the Alpha colour issue.


(Simon Maddox) #10

@cric have you added the RWSupportsAlphaInColours key (and set it to YES) in your RWThemeCapabilities dictionary?

If so, could you send a copy of your theme to support@realmacsoftware.com and let them know I sent you please?


(Chris) #11

Not exactly. I set this as a boolean true in the RWThemeCapabilities dictionary:

<key>RWSupportsAlphaInColours</key>
<true/>

Let me know if this is wrong and how to do it then.
Chris


(Simon Maddox) #12

That looks fine to me. Could you email the theme to support so we can take a look please?


(Frank Land) #13

With the newest 7.03 Beta3 i get this Message ! Why? Never had such a message.


(Jannis from inStacks Software) #14

Maybe that is related to the inbuilt PHP preview server.


(Frank Land) #15

But is this new in RW 7.03 Beta3?? The Firewall asked for this.


(Tom Bradley) #16

Hey guys,

The firewall alert is indeed related to RapidWeaver’s use of a PHP web server. The latest version 7.0.3 beta 3 should fix an issue where some people were seeing an empty preview page, but the fix also caused this firewall alert issue. This should be fixed in the next beta :wink:


Programm "php" eingehende Netzwerkverbindung?
(Michael M.) #17

There was an php-option in the firewall settings set to “do not allow”. To change the settings in the osx firewall you must be an admin and RapidWeaver has no admin rights. Its not possible that RapidWeaver can change the settings without permission by the user


(Tom Bradley) #18

No I know. Maybe I should have been a little clearer there, we’ve found a slightly different way to apply the fix that doesn’t cause the OS X firewall to jump into action.


(Dean) #19

7.0.3 does not fix the preview issue for me