RapidWeaver 8 Mobile Display Issue


(Jason Bostick) #21

The bit in between the <frameset></frameset> is your iframe. The fact that goulian.com/lockkill works fine on all devices (and uses the same theme), suggests that it is not the theme that’s the issue.

Are you using domain masking with GoDaddy? Because when I google that, there are lots of users noting that forwarding their domain causes it to lose responsiveness.

Even though Ben and others suggest that you should leave GoDaddy, I have had sites hosted on there that work fine. And while they wouldn’t be my first recommendation, it isn’t GoDaddy per se, it is that you are using one of their services that incorporates an iFrame, and that iFrame is causing your site to not work on mobile.

Can you not just create lockkill.com as an add-on domain and publish to it like you would any other site instead of using their domain forwarding?

(By the way, I don’t speak with any authority on hosting-related things, so don’t take the above as gospel or anything. Just putting 2 and 2 together.)


(Rick Goulian) #22

I’m still not seeing an explanation of WHY this frameset is suddenly an issue with the new responsive themes, and has never been an issue with older themes. Keep in mind this code is out of my control - I did not put it there and I have no way to remove it. I have now switched to forwarding w/o masking. Tonight I’ll try the Mountains theme with that setting and see if it works.


(ben) #23

Is this a new domain name? Or have you changed the hosting setup in any way?

I’m having a hard time seeing it’s RapidWeaver’s fault when browsing the site via the direct URL (http://www.goulian.com/lockkill/) works, but when viewing it through the GoDaddy HTML-modified version (http://lockkill.com) it does not — key point is that GoDaddy is modifying the HTML code, by serving the site through an iFrame/frameset.

The iFrame is certainly causing an issue with the site.

I’d be more than willing to — ben@realmacsoftware.com

I think @jabostick has hit the nail on the head here.

I wasn’t trying to say RapidWeaver is incompatible with GoDaddy (there are plenty of users who host with them), rather I was trying to say that I believe the iframe being added by GoDaddy is the issue.

I’m not a GoDaddy user, so I can’t say why the iFrame is being added, or how to remove it — but as I mentioned previously I think you need to host the site correctly — by that I mean it needs to have it’s own hosting rather than using “domain forwarding” (or whatever GoDaddy call it) and your site therefor being wrapped inside an iFrame.

Again, hope that helps and let me know if I can do anything else to get this resolved.


(Rick Goulian) #24

So, I am now hosting the LOCKKILL domain directly on GoDaddy instead of making it a sub folder of GOULIAN.com and I also removed the domain forwarding. This did indeed fix the theme issues my website shows all the content on iOS devices. I also agree this is the better way to host my website. Thanks to all of you who weighed in on this and helped steer me to a solution.


(Robert Ziebol 🖖🏼) #25

Glad to hear you got it working, I would suggest clicking on the checkmark of the post that helped you the most, this will edit the title to include SOLVED in it, so people will know your issue is solved.


(Patricia Bridewell) #26

I am having the same problem with the RW8 themes. Only on the iPad it doesn’t show full content in Safari, Chrome or Firefox. Android is fine, all other web browers are fine.

I don’t understand what I need to do. My registrar is Google and I am hosted at webmasters. com

I do not see where to check if a stack is disabled for mobile.

My site is patrish.com
If I access it on the iPad as patrish.com/index. html it works fine. Until I click on home (patrish. com) again.

I, too, tried the other RW8 themes with same result.


(Ken) #27

@jabostick Rather than forwarding a domain on Goddady, its better to create a “Sub-Domain” which then works fine in IFrame. The sub-domain name uses the ‘www’ for the domain i.e. https//sub.mydomain.com. The sub can then be created responsive using appropriate RW and addons (or even a generic RW Theme). A lot of people castigate Goddady but in my experience, its mainly because of lack of understanding at how Goddady handles sites. Users of Godday versions of several years ago did lack certain aspects required by addons but if you signed up in the last couple of years it’s fine. For example, I couldn’t get Armadillo to work on an earlier Godaddy host but with the version I purchased 18 months ago it works fine. I personally like Goddady because there is no limit on site sizes and one can add unlimited numbers of sub-domains.


(Patricia Bridewell) #28

Okay… I am not on GoDaddy, and my domain is not being forwarded. I am on Google Domains and changed the DNS server to that provided by my webhost, Webmasters. It is the master domain on a true server. I have now tried each of the RW8 themes and my iPad doesn’t like any of them. I don’t know whether I need to find a different setting in RW8, contact Webmasters, contact Apple, or contact Google. I really don’t think it would be Google because they only are my registrar.

I also used the site inspector tool in RW8 which gives me a clean inspection.

I do see frameset in my front page, but it is not put there by my settings as far as I know. Another thing: the full site path is not showing up on any of my pages, just the patrish.com. Is there a setting for that?

(Again, this is only a problem on the iPad, and the same result on all browsers… Maybe it is an iPad setting?)


(Patricia Bridewell) #29

AHA!!! SOLVED!!!
I turned off (in iPad settings) ASYNC FRAME SCROLLING, found in Settings / Safari / Advanced / Experimental Features


Responsive themes not working using OS X Server on Yosemite
(Don H) #30

I don’t think I’d rely on that as being solved. I doubt your visitors will have the setting turned off on their iPad. The site won’t work well for them.

Something is putting your webpage inside an iFrame (frameset). It’s most likely your web hosting (Webmasters) that is adding that. I’d start by asking them why.