RapidWeaver 8 Mobile Display Issue


(Rick Goulian) #1

My new RapidWeaver 8 website looks great on browsers and previews fine on iPad and iPhone, but on the iOS devices the content is missing and just the banner & logo shows. Has anyone else experienced this?


(Doug Bennett) #2

I assume you’re double posting this because you didn’t get a response from yesterday’s post?


For future reference it might be cleaner to just add to the original post, but no matter.

For an issue like this a URL to the site would be of great help.


(Brian LaPan) #3

I deleted your old post. Please do not double post.


(Ric) #4

@dgoulian

Like you I’ve put up a couple of posts recently, with a reasonable question asking for help, and no replies.
What a shame that your only replies are being ‘told off’ for asking twice!
The forum is usually better mannered than this.

Teeters is right on one thing though, that a URL would help. Send us a link and hopefully you’ll get a response.


(Greg Schneck) #5

Is is possible that you have accidentally checked “Hide this Stack on Mobile” for your main content stack? (Page Inspector pane.)


(Rick Goulian) #6

Yes, its a double post. My apologies but I was expecting an email if I got any replies. The website site I am having trouble with is www.lockkill.com.

Looking forward to any help.


(Rick Goulian) #7

I will check this setting when I get home tonight, but I am having the issue on the home page too, which is not a stacks page.


(Rick Goulian) #8

The website is
www.lockkill.com

Thanks!


(Rick Goulian) #9

Found the settings to notify via email if I have a reply…


(Doug Bennett) #10

Yeah,
I can confirm that just on both an iPad and an iPhone (actual devices)that only the hero displays. On a desktop browser (chrome) simulating mobile, it displays the main content.

This is a new RW8 theme, so I would ask if you tried a different theme? That would help determine if it’s theme.
I can tell you that the theme is getting errors (404) on some fonts not found. That wouldn’t cause this error but should be addressed be RealMac @ben.


(Rick Goulian) #11

OK thats probably a good clue. I’ll try another theme I guess. But I used the mountain theme out of the box and did not mess with fonts. It makes me wonder if RealMac tested this theme on real devices before shipping.


(Jason Bostick) #12

Is it iFrame related? Because if you go directly to the site that is being iFramed - that seems to work on an iphone and also uses the Mountain theme

(edited for clarity)


(Rick Goulian) #13

Quite possible its related to GoDaddy forcing the website to be inside of an iFrame. But not sure what to do if thats the case. I don’t see any settings on GoDaddy to remove this. Suggestions?


(Rick Goulian) #14

As noted by others, I am getting 404 errors apparently the site is trying to load a .woff file and can’t find it. Thats a Web Open File Format font - so I’m guessing RapidWeaver did not upload this font to the server? Sounds like a RW 8 bug to me. Hopefully RealMac can weigh in on this?

404%20error


(Jason Bostick) #15

Ah, I didn’t realize that the iFrame was a GoDaddy implementation…

You’re correct that the font errors may be a bug in the theme, but you get those errors both on the http://www.goulian.com/lockkill/ site as well as the http://www.lockkill.com/ site, so I wouldn’t think that is the root of the iphone display issue


(Joe Workman) #16

One of the many reasons why almost any other host is better…


(Rick Goulian) #17

OK, did some tests with all 5 new RapidWeaver 8 “Responsive” themes. Only 1 out of 5 worked correctly on iOS devices:

  • Mountains, Engineer, Climate - Shows NO page content
  • Future (only shows partial page of text)
  • Artful shows entire page

So, since Artful works fine and the other 4 don’t, its obviously NOT a GoDaddy issue. Its an issue with the new responsive Themes on iOS. And since I upgraded to this new version of RapidWeave expressly for the new responsive fonts, I will either need this fixed quickly or I’ll need a refund.

Please advise next steps RealMac.


(Doug Bennett) #18

If you can put a copy of the project file out on something like Dropbox. Send a link to it to Dan (@relmacsoftware.com) with a brief description and a link back to this post. I sure @ben will want to have a look.


(ben) #19

Hi @dgoulian,

Sorry you’re having issues with the new themes! This is the first case I’ve seen of any site built with any of the new themes not working on iOS devices.

Here’s my tl;dr version: Stop serving your site through an iFrame, it’s causing the content to be un-scrollable on iOS. I would suggest you use a different host, I wouldn’t recommend GoDaddy to anyone. My best guess is you need to get some proper hosting for the lockkill.com domain name.


Firstly, missing fonts will not affect the display (as in being able to actually see it) of content on your site — it would just mean the font would fallback to a default, “web safe”, font.

As for the issue with not seeing the content, as mentioned by @jabostick, http://www.lockkill.com/ is being served through an iFrame - with the actual site being hosted on http://www.goulian.com/lockkill/.

If you visit http://www.goulian.com/lockkill/ on an iOS device then everything works as expected.

Side note: If you look closely on http://www.lockkill.com/ you’ll notice that the content is not responsive — the site logo and hamburger menu icon are not sized correctly. Compare those with http://www.goulian.com/lockkill/. This is down to the way the iFrame is setup, it’s messing with how Safari is treating the site — Safari is displaying it as a “non-responsive” website. The content is being squashed down to fit the viewport, this is not a theme issue. That’s an issue with how the iFrame is setup.

As for why you can only see part of the content on iOS, that is also down to the iFrame.

The iFrame is actually larger than the viewport on your iOS devices, which is why you can scroll down and see the site title and slogan. However, the content inside the iFrame is not being scrolled, and this is the main issue for you.

I’m not sure why the content ins’t scrolling inside the iFrame (my iFrame knowledge is a little rusty — it’s 2018 and I haven’t used an iFrame for quite a few years now), but it shouldn’t be in an iFrame in the first place.

I’m guessing that you don’t have the correct hosting setup for the lockkill.com domain, perhaps you are using the same server as your http://www.goulian.com/ domain, and GoDaddy allows you to set up an additional domain and serve that via an iFrame? This is just a guess, I don’t know how you’ve set things up…

Whatever you do, you need to remove the iFrame and point the http://www.lockkill.com/ domain name at the server that is hosting the content — unfortunately I can’t tell you how to do that with GoDaddy. My advice is to switch hosts.

Do let me know if I can help any further.

Cheers,
Ben


(Rick Goulian) #20

Hi Ben, thanks for responding. But could you explain what you mean when you say “Stop serving your site through an iFrame”? Here is what I see when I look at LOCKKILL.COM using Chrome web inspector:

I don’t see an iFrame. I’m still leaning toward this being a RapidWeaver defect. Blaming GoDaddy is pretty convenient and since I have been hosting this website for well over 8 years with RapidWeaver, I’m having a hard time believing that suddenly GoDaddy is the culprit. The only variable in the equation is RapidWeaver 8 and the new responsive themes. Don’t forget that one of the five new themes works fine on GoDaddy (the one that is up there right now). The other 4 don’t show the content. So your telling me that and iFrame is causing a problem only sometimes? And It did not cause a problem at all with RapidWeaver 5, 6, or 7? Does not make sense. I thinking the situation is that RapidWeaver is no longer compatible with GoDaddy which is the world’s largest web host by market share. I’d be a little more concerned about that if I were you.

But I’m willing to keep an open mind. If I send you my website can you post it in a private non-GoDaddy site? That would prove your point pretty well, don’t you think?

The bottom line here I have a website that no longer works on iOS devices, so I’m losing revenue every day that this issue is not fixed. If you are going to insist its Godaddy’s fault without showing me solid technical proof, then I have no option but request a refund and go to another product. I think you would do the same in my shoes.

Rick Goulian