Re Published all files but page still exists that I hid/removed


(Leigh Stone) #1

I’m working in Rapidweaver 7.5.6, trying to hide a tab on my website.
https://crybabystudios.com/applyforgrant/

I first tried by unchecking “show in navigation” in the inspector box and republished. This worked for another page in the past that I wanted to hide but not delete but it did not work for this page. I cleared the browser cache and previewed the site on FIrefox from RW and it seems to be gone but when I republish it persists.

I tried republishing ALL files and went as far as making a copy of RW program file then removed the page completely and republished - the APPLY FOR GRANT page is still there.

I host through CPanel on GoDaddy and see the file there, even removed it, but still persists!!! I really need to axe this page today, any guidance is greatly appreciated!!

thanks
Leigh

Here is the site itself and not the page I am trying to remove:
https://crybabystudios.com/


(Ric) #2

It’s strange that by unchecking ‘show in navigation’ the page navigation structure persists. If it isn’t showing in RW but shows in a browser I’d strongly suggest it’s a browser cache issue. Try viewing the site with another browser.

Another suggestion might be that you have two versions of the page. You have forms on the page which suggests a .php extension. I wonder if when you originally created the page you made an html page then added the forms after thereby creating a php version and have publised both to your server.
You will need to manually delete both files. RW doesn’t delete content for you.


(Leigh Stone) #3

I’ve tried multiple browsers on different devices even. I just removed some files on my Cpanel and broke the page…
https://crybabystudios.com/applyforgrant/

I republished it again and still the APPLY FOR GRANT tab shows but now when I click on it it’s messed up and the navigation is gone. uh oh. Here is my Cpanel…

L


(scott williams) #4

What is inside the public_html folder, that is where your site “should” be


(Leigh Stone) #5

That is where I removed the files from the apply for grant page…
See the daily rental folder, that’s page that I unchecked the box “show in Navigation” and it removed it fromt he published site…it’s not working with apply for grant. And now that I removed all the files it’s toast :confused:

Can I just wipe everything from the Cpanel and republish? Or is that asking for more trouble?? thanks so much for the help everyone!


(scott williams) #6

Show your publishing settings


(Leigh Stone) #7


(scott williams) #8

Hit that browse button by path,
Select public_html, that’s where you should be publishing to.

On each page (inspector):
The filename should be left as index.(html/php)
The folder name should be whatever you want the url to be for that page. Ie. events

In the example above the url would end up as: yoursitename/events

Hopefully that makes sense


(Leigh Stone) #9

cool. I cannot use any non AN characters in the filename, so no () ?


(scott williams) #10

You should leave your file name as index. Unless you have a real good reason not to, index is the default file name that is served so users don’t need to remember it.

You should make your folders (lowercase, no spaces, use a _ between words if multi word) if you can name them a keyword that’s even better.

Then in your .htaccess file make sure you have rules to redirect http -vs- https and www -vs- no www

Example: https://www.YourSite.com/news/index.php

The user would only need to know YourSite.com/news to get there


(Leigh Stone) #11

YAY!!! thank you for spending this last hour helping me out. Have a wonderful rest of your day.

Leigh


(scott williams) #12

You are welcome