RW 7.3 bad 'addon updates' bug


(Alex) #1

Hi all.
Since updating to v7.3, I keep getting the ‘Addon Updates’ notification for 2 (old) themes that link to URLs that don’t exist - see pic.

Both are from SeyDesign (although the links are to the old Nimblehost server). Neither appear as updates when I run (Nimblehost’s) Waterfall. I presume they’re triggering some odd flag in the new build of RW that thinks they need updating.

Any ideas how to stop this? Its an annoying dialogue box I don’t need.
Thanks
Alex


(Gary) #2

Is there no option to turn the update checking off? If not this is badly needed as there will be untold issues with this fantastic new feature in 7.3.


(Alex) #3

Not that I can find. The only RW update option to turn off is for RW updates, not Addon Updates.
This is presumably a retro-compatibility issue that has selected these 2 themes from many due to a random false flag.

I want to know about relevant updates. I don’t want to know about erroneous ones (for themes that will likely never be updated again).


(Doug Bennett) #4

On seydesign website those both are old versions
Alltr is version 5.0
Kleer is version 2.0

Not sure why waterfall is not picking this up.
Maybe has to do with the change over of saydesign to @willwood or could be a conflict with the old waterfall update with the new feature in RW7.3.


(Alex) #5

Thanks. That explains why the ‘i’ link & the ‘Done’ button tries to link to a non-existent page on the Nimblehost server then.
Odd that all new shiny Addon Updates has selected those 2 from my 70+ theme library.


(Peter Danckwerts) #6

The reason that those old themes are not showing in Waterfall is, I think, due to the fact that they are pre-Waterfall versions.The Waterfall update feature had to be built into themes before it would work.


(Doug Bennett) #7

Waterfall should tell you that theme has no information and not that it’s current. The new RW7.3 theme update feature uses sparkle just like waterfall does to determine if there is an update. Within the theme there is a URL that waterfall or RW7.3 goes to to check for updates.
If this was a pre-waterfall version then why is RW going to a nonexistent URL?


(Brad Miller) #8

I just upgraded to RW 7.3 this morning, AFTER I made updates to two of my sites using RW 7.2.x. I am having this same issue with the same 2 themes. I have contacted @willwood about possible updates already.

Further, neither one of my sites will publish now and seem to get stuck on the publishing page.

RW 7.3 cannot seem to log into my sites via ftp, even though I can still get into cPanel and CyberDuck using the same credentials. Grrrr…


(Doug Bennett) #9

Not sure what is going on with the new theme update feature. Will has an update page on the seydesign site.
https://seydesign.com/support/updates/


(Brad Miller) #10

I just went back to RW 7.2.2 and successfully updated 2 pages on my site.


(Alex) #11

Will has rapidly responded to my update request for the old themes; all now run fine & don’t trigger the random update window. No FTP problems with 7.3 for me.


(Brad Miller) #12

Does anyone know how to do a clean install with RW? Since I had issues with the 7.3 upgrade, I’m thinking it’s time to clean up my RW install. I have been using RW for about 5 years, so maybe it’s time.
Thanks.