RW8 - Lander theme Fonts and Icons not showing after update


(Tim Teichert) #1

After updating my “Lander”-themed Website from RW7 to 8 the Bree font and the fontawesome icons don’t show anymore.

To figure out, if this is Version related, I tried loading up an older RW7 Version - and voilá – all the fonts and icon show up correctly.

Is this a known issue? Is there a work around to fix this?

This is the site I am refering to:

And here is the RW7 Version:
fantastic-friday.de/RW7


(Robert Ziebol 🖖🏼) #2

In RapidWeaver 8 do you have the Privacy Checkbox “Anonymise requests to third party servers” checked? If so, uncheck that and see if it works. If not, not sure what might be happening.


(Tim Teichert) #3

Thanks for your feedback. The Checkbox was unchecked.


(Tower) #4

I’m having the same problem. Created a site in RW7 with the Lander theme, updated to RW8, and now Font Awesome icons are broken. They display correctly in preview mode within RW8, and also when previewing in Safari from RW8, but when published to the server they are broken. Research reveals that this type of issue could be related to missing MIME types on the web server, but I verified that they are all configured correctly.


(Tower) #5

Figured it out: the fonts folder is published at /rw_common/themes/lander/fonts but the code references it at /fonts. I copied the fonts folder to the web server root and all is good.


(Tim Teichert) #6

Perfect! Worked for me too! Thank you very much for your efforts!