Setting path to private key file in publish with sftp settings


(mike) #1

In the SFTP settings UI after selecting the private key file and clicking OK, Rapidwaeaver (v 6.3.7) throws this error message: “Couldn’t save a referance to your key file”.

Setting the path to the public key file works fine. The keys themselves are fine as they work from ssh in terminal and from other apps and utilities such as Coda 2, Filezilla, etc.

Any ideas what Rapidweaver is trying to tell me?

Thanks,
mike


(mike) #2

Never mind. I had the file permissions set to 400 on the private key file. Changing to 644 fixes the Rapidweaver issue and ssh still works. Apologies for the unnecessary post.


(mike) #3

Ok one last point just in case anyone else ever runs into this. Setting the file permissions on your private key to 644 is a bad idea. You don’t want anyone else who can log into the system to be able to read that file. You should set it to 600.

BTW Doing this enabled me to set up publishing from RapidWeaver but publishing doesn’t actually work yet. I’m not sure why but figuring it out is an exercise for another day. I can just copy files from some other utility (or the command line) until I have the time to track down what’s going on with RapidWeaver in the logs.


(mike) #4

OK one more last point. No really.

I finally got back to working on this. I’m think I must have been typing the port number wrong in the publish settings before. Or maybe I wasn’t entering it all. So the fix, I believe, is to format the SFTP publish setup server setting like this: “website.com:22”. Anyway that works today.

Regards,
mike


(Brad Halstead) #5

Awesome info @unamike, thank you for updating the forum with the information and troubleshooting processes you persevered through.

Brad


(Lou Arthur) #6

RW 7, trying to connect to AWS EC2. I point rw7 to the foo.pem file and get “Couldn’t save a reference to your key file” error. I tired changing perms but no help. have you run into this with rw7?