Cannot publish from Rapidweaver


(Elaine Sanderson) #1

Please help - I keep getting this message when publishing in RW 6.3.8 and have been trying a whole week to sort it. the message is:

"couldn’t upload to your SFTP server. Failure when receiving data from the peer"
tried restarting/reboointg/ range server company several times/ exporting and still no luck.

then to make things worse my whole site formatting has gone when live - just show missing images and lines of data - god know how.

No-one can seem to help - even paid £70 for a new version of RW hoping tha would sort to - losing business fast!!!

I am using these settings:

Protocol: SFTP
Server: olympus.krystal.co.uk
username sandscom
password - my password
path: public_html/sanderson-windows.co.uk

and it show that these details are correct when I test the connection.

Server company tell me I meed to use PORT 21 if I am using FTPS and PORT 722 if I am using SFTP but I have no idea where to find this to change / edit ti in Rapidweaver?

nightmare - any help?

Thanks

Elaine


(Brad Halstead) #2

Continuing the discussion from Cannot publish website:

Answer is in my reply to your original post…

Add port number to server

i.e.: olympus.krystal.co.uk:722 for sftp

I still think your website root is incorrect, but I don’t use that host so will reserve judgement. :slight_smile:

Edit, if this is an add-on domain, then the root would be path: sanderson-windows.co.uk as per these instructions for best case use

HTH
Brad


(Elaine Sanderson) #3

Thanks Bradford that…

Just tried adding olympus.krystal.co.uk:722 for sftp and now the error message is:

Couldn’t upload to your server. Error in the SSH layer?

elaine


(Brad Halstead) #4

Is SSH enabled in the cPanel for that add-on domain?

Did you generate a public/private key set for the SSH? If yes, they have to be entered into RapidWeaver Publishing Credentials for SFTP (Gear icon next to Protocol…

Are you using the correct username and password for that add-on domain as configured through cPanel?

Lets get back to basics and make sure FTP works

Change Protocol to: FTP

Change Server to: olympus.krystal.co.uk

Change path to: sanderson-windows.co.uk

Can you publish?

Their FAQ’s sure were difficult to find, so much for user friendliness :wink:

Brad


(Elaine Sanderson) #5

hi there Brad - glad to feel someone there!

There are no public keys installed under the the Ssh settings in channel.

yes I can log into FileZilla ok with that domain and password so they are ok

Changed to FTP and olympus.krystal.co.uk and public_html/sanderson-windows.co.uk and still no luck

so frustrating - been using RW for years and never had problem until now!

Elaine


(Elaine Sanderson) #6

maybe I should just delete the whole website from my server using FileZilla and upload again from fresh from Rapidweaver but scared of doing this as it seems so drastic and might affect SEO?

thanks

Elaine


(Brad Halstead) #7

Hi Elaine

What does no luck mean? what error message? Please be as descriptive as possible.

Not all recommended changes were made…

Change this: public_html/sanderson-windows.co.uk

To this: sanderson-windows.co.uk

Try publishing again

Out of curiosity, did you download and install RW 6.3.8 from here or did you do an update from your computer? If the latter, close RapidWeaver, download and install from the link above and restart RW. Open your project and attempt publishing again (may require a computer restart).

I wouldn’t do that until you know you can publish!

Do you happen to have any firewall software or anti-virus installed that may be causing a connection issue?

Doing my best to assist you but am unfortunately, out of ideas after this other than to contact support@realmacsoftware.com

Brad


(Brad Halstead) #8

@sanderson01

Elaine, any progress on this issue?

Brad


(Elaine Sanderson) #9

Hi Brad

Sorry I had to go away for the weekend. I tried downloading again from your link and I tried publishing with sanderson-windows.co.uk and not public_html/sanderson-windows.co.uk

tried Changing Protocol to: FTP, Changing Server to: olympus.krystal.co.uk and Changing path to: sanderson-windows.co.uk and still no luck.

something must have published somehow though as the whole site is messed up with just lines of text and no images now so in a right mess.

Contacted Rapidweaver and the said they will test their end but quite slow!!

Thanks

Elaine


(Brad Halstead) #10

Hi Elaine

The site looks good from my end…

Could it be a browser cache issue? Try Clearing browser cache

Some pages load a little slow due to image physical size in MB but you can optimize those down I am sure using PhotoBulk.

Brad


(Elaine Sanderson) #11

Thanks Brad

After 9 days of trying to sort the problem I spoke to my web server comply and got through to someone who knew that they were taking about and they sorted it - it was port 722 I needed with SFTP

thanks so much for all your help!
Elaine