Sidebar - can I change the size or remove


(Mary Davidson) #1

Hello

Can anyone help please. I’ve created my website using the LANDER theme. I’ve used the “master style” for every page but now want to add a simple Styled Text page with a mixture of text and photos but without a Sidebar. I can’t see how to do that. I’ve looked in the Page Inspector and I see a bit called “Breakpoint: Sidebar” and various size options but it’s greyed out and to access it I need to uncheck the “master style” box which then applies the changes to every page not just the one.

I’m thinking I need to add CSS code. Can anyone help please.

Thanks


(Greg Schneck) #2

Most themes (all?) have an option (checkbox) to turn sidebar on and off. Look down thru your theme settings. You’ll save a unique sub-style. Name it something like “Main, No Sidebar”

(From memory - your experience may differ.)


(Mary Davidson) #3

Thanks so much Greg, much appreciated. I’m searching through the theme for a checkbox that will turn the sidebar off … but not having much luck :frowning:


(Henk Vrieselaar) #4

Paste this in the Custom CSS:

#sidebarContainer {width: 0%;} #sidebarBackground {display: none;} #contentContainer #content {padding: 0;width: 100%;} #contentContainer{padding: 35px 4%;}

Henk


(Mary Davidson) #5

Henk you are a genius … I pasted your CSS code and the sidebar on that page disappeared!!! Thanks so much. :+1::two_hearts:


(Robert Ziebol 🖖🏼) #6

Not sure why no one showed you this setting, which will turn the Sidebar off for you in the theme settings:


Make sure you uncheck Use Master Style and then find the BreakPoint: Sidebar setting and click and choose Page full width (Hide Sidebar) and this should remove the sidebar WITHOUT you having to add the code. Glad the code works, but this is a better solution.


Help ... I'm trying to add photos to a Styled Text page
(Mary Davidson) #7

Hi Robert - thanks for your help re the Sidebar. I did try unchecking the Use Master Style box before I sought help on the forum, but I came up against a problem. I only wanted to remove the sidebar on that one page, I needed a sidebar on all the other pages, and unchecking that box seemed to affect the whole site.

I entered that bit of code on that one page only and like magic the sidebar disappeared! :slight_smile:

Thanks again
Mary


(Robert Ziebol 🖖🏼) #8

Are you sure you checked the box and did not push the edit button, as you can see from this video
http://d.pr/v/gFXm
It works just the way it should, you uncheck Use Master Style on one page, but it stays on the others. If you clicked edit, it would remove it from all pages, as that is the new master style.

I am glad you got it working, just trying to show you that code is not needed, and I am not trying to undermine what @henkvrieselaar has done to help you. Just pointing out the simpler solution.


(Henk Vrieselaar) #9

You’re right, Robert. I hadn’t noticed this option.
Henk


(Mary Davidson) #10

Oops … I pushed the edit button!!! Sorry guys. Hope you don’t feel I’ve wasted your time. I spend ages Googling my queries, searching You Tube videos, searching around the RW Forum and really only start a new help topic in desperation when I’ve drawn a blank everywhere else.

Great little video Robert, thanks so much Robert. Henk, thanks again to you too - everyone’s been so helpful with this,