How do I hide the sidebar?

Hi Everyone
I have studied the advice above about removing the sidebar menu. I am using the most current version of RapidWaever (2024) and despite clicking on the “Hide Sidebar” option, I can’t seem to remove it. I was baffled by zeebe’s image of the Master Style theme setting as the only thing in the Page Style > Theme Styles > Sidebar is the option to display left, right or hide. I chose Hide but there are no changes. I then purchased 1LD Clean Menu and I thought I might have more control at hiding the sidebar menu but no. I now have 3 menus (sidebar, top menu and hamburger menu). My site is small ( and the sidebar is just taking up space. What am I missing here?

Maybe putting the following code int the area for custom css could help:

#sidebarContainer {display:none !important}

Looks like you are using the built-in Small Business theme. The hide sidebar theme setting seems to be working fine here when I test it.

If the hide sidebar setting is not working in the theme settings, there might be something conflicting or overriding it in your project. You can send over your project file if you’d like for us to check.

Thanks Matthias. I added your code and it works by removing the sidebar menu but the blank column is still present. I have not selected any theme, by the way.

Thanks dang. I can remove the menu by entering the code but the empty sidebar space remains. It is now an empty column, despite me clicking on the “Hide Sidebar” command.
As soon as I can work out how to ‘send over the project’ I will try to do so.
Thanks again.

Hm, strange. You are saying that you don’t have selected any theme. But you must(!) have selected a theme, since you can click on “Hide Sidebar” in the theme settings… :wink: Looking in the code of your website I see that it’s the “Simple Business” theme you are working with. I think I got the solution for you: When you click on the Master Style theme setting and select to hide the sidebar the sidebar is not hidden. The reason for this is probably, that you have selected to not use the Master Style on the single pages. Just go to the Page Style settings in the inspector panel and either select to use the Master Style (which you set to hide the sidebar before) or select to not use the Master Style and then select to not use the sidebar (see screenshot). This you would have to do with each of your pages. Hope this helps… :slight_smile:

1 Like

Hi Matthias

Fantastic, thank you. It worked. Thought I was losing it. But I am new to RapidWeaver.

Thank you again.

Best wishes


1 Like