Solved > Deleting Partials, watch out?


(tim parsons) #1

Hi All, i wonder if anyone else has had this trouble ?, i have sent off my Project to Realmac and am waiting for a reply.
But in the meantime, i do believe i have found the cause and it was all my doing.

I created quite a few Partials and kept editing them and deleting some and creating a few more new ones.

Eventually i found when Previewing the Page, the page had no contents, in Edit mode the Partials had no content either. AND believe it or not all the Partials i deleted are all back in the list !, but the ones in the empty page are of course all empty !

Has anyone else done this ? and like me, ended up with egg on my face !!

Tim


(Brad Halstead) #2

Hi @timmytoad

Partials won’t die if you have them on a page in the site, you have to unpack them on every page of your site to have the ability to delete them.

Conversely, if you have a partial and it is not used it dies on save/close/reopen of project file.

If a partial is in a partial then the same applies. Inner partial unpack first then external partial.

You might want to submit a support ticket through YourHead @isaiah or @girlcarew with a sample project file exhibiting the behaviour but it is going to come down to the fact of making a page that exhibits the behaviour that is as simple as possible for troubleshooting purposes.

HTH
Brad


(Isaiah Carew) #3

since this only involves Stacks you should probably send this to YourHead :slight_smile:

ok. follow you so far. to paraphrase:

  • you’re doing some unspecific stuff.
  • sometimes adding / removing partials from some pages.

correct?

ok. woah. you kind of jumped ahead there.
suddenly while doing non-specific stuff – everything was gone. i suspect there’s some missing detail in between that’s probably relevant. :stuck_out_tongue:

done what exactly? non-specific stuff? adding / removing partials. yes. i’ve done this a whole lot. :stuck_out_tongue:

i suspect you mean some other stuff – something in between the non-specific stuff and when everything disappeared.

Although I’m not positive these will help, because I’m not sure I understand the issue at hand, I think it’s probably worth posting these just for other people that visit this thread:

This is a post about how you can’t really “delete” a partial from the Library if you’re still using it.
http://cafe.yourhead.com/?qa=123/how-do-i-delete-a-partial-from-the-stacks-library

This one is about how to delete a partial instance from a Stacks page
http://cafe.yourhead.com/?qa=122/how-do-i-delete-a-partial-stack-from-a-stacks-page

And this one is how to “unpack” a partial.
http://cafe.yourhead.com/?qa=124/what-does-the-unpack-button-do

If I had to guess at “everything is blank” sort of error there are probably a few possibilities:

  1. Styled Text problems
    If you paste in styled text from other apps into RapidWeaver it can cause the rendering engine to go a bit nuts. This can sometimes result in totally blank output. If you recently pasted content from somewhere I’d check on that first. More info: http://cafe.yourhead.com/?qa=47/why-does-text-copied-from-other-apps-look-strange&show=47#q47

  2. Code bug
    If you edit some HTML, CSS, or Javascript and make a syntax error – like leave out a closing ‘>’ then it can corrupt the entire page. Totally blank output is rare, but not unheard of. If you’ve recently edited any type of code in your document check that. Solution: fix the code.

  3. Something crashed
    It could be that something somewhere in RapidWeaver or Stacks died for some reason – and the app has tried to continue on to let you save things and exit smoothly. If restarting RapidWeaver resolves the issue then this is likely your problem.
    Solution: not your problem. :wink:
    If that’s the case, then it’s nothing you’ve done – and there’s nothing to worry about or “solve” – it’s simply a bug that someone needs to fix (probably me). Collect as many error messages and details about exactly what you were doing right before the problem occurred and send them to me – and I’ll do my best to find and fix the bug.


(tim parsons) #4

@isaiah Wowee isiaiah, I didnt deserve anyone to goto sooo much trouble and time to explain what i experiencing. Thanks you sooo much.

Thanks also for the links, i obviously ABUSED the whole PARTIALS facility and wasted a lot of Time doing it. I was trying to be too clever, it might have been summat to do with my brand new slimline MacBookPro, i was trying to go too fast.

I shall in future Slow Down and be more methodical, which is what Partials are encoraging us to do :slight_smile:

Thanks again @isaiah

Tim


(Isaiah Carew) #5

i take data-loss pretty seriously – so when i see “everything disappeared” i try to jump on that as quickly as i can.

partials are unchanged since long before the 3.0 release – so i don’t suspect they are suffering from any major data-loss bugs, but better safe than sorry. :slight_smile:

if you discover more details about your issue, let me know, i’m here to help.

isaiah


(tim parsons) #6

I have NOW found out what i am doing wrong.

I make a Partial but when i want to Edit it, i UNPACK IT AND EDIT IT, i can do that OK

BUT when i go BACK it doesnt seem to PACK it again, it just creates another Partial with a random number ???

What am i doing wrong Please.

Tim


(Brad Halstead) #7

@timmytoad

Don’t unpack it, instead double click on the partial header on a page that uses it and it will open into edit mode, make your changes and click the Back button and changes are saved in the Partial.

HTH
Brad


(tim parsons) #8

well i’ll be dammed, you are spot on Brad, thanks you have made an old man VERY HAPPY :slight_smile:

Therefore why have an UnPack button in the first place ? if it causes problems like i was experiencing ?

Tim


(Isaiah Carew) #9

Why have unpacking? There are probably some interesting use cases, but primarily it’s just because any grouping sort of action in an app needs a corresponding ungroup, just in case you need to undo the operation sometime later.


(tim parsons) #10

Howdy @isaiah thanks yet again for your valuable input, along with Brad :slight_smile:

I was only expressing my concern at only having trouble with the Parial UnPack button. which allegedly gave me more than a few problems.

I havent had ANY problems at all, IF/WHEN i open a Partial by simply clicking on the Label :slight_smile:

Tim


(Isaiah Carew) #11

Just to clarify for everyone who reads this in the future:

You can edit a partial by double-clicking on it or selecting it and clicking the Edit button – which is, of course, the same way that you edit everything in Stacks. :slight_smile:


(tim parsons) #12

“Unpacking a partial takes all the contents of the partial and places them at the current location on the page. This is a good way to undo the operation of creating a partial.”

It has now sunk in to my old Grey Matter, that the cause of all my troubles was simply because :- I was UnPacking when i should have been Editing !!!
I also discovered that there are two ways to EDIT, double click the Partial OR highlight the Partial and select the EDIT button. To be honest i hadnt even seen the Edit button !!!, it isnt available until a Partial has been selected.

Thanks @isaiah for being so patient with me all through this Thread :slight_smile:

http://cafe.yourhead.com/?qa=124/what-does-the-unpack-button-do4