Stacks 3 Partials Keep Disappearing


(Peter Rood) #1

Hi Everyone

I upgraded to Stacks 3 a few days ago. I love the partials feature. It is a real game changer. I only have one problem… for the second day in a row my partials have disappeared and restarting my computer. All my work down the drain again. The funny thing is, is that not all my partials have disappeared. The first few I made are still there.

I restored my project file from Time Machine since I I know I saved my project several time yesterday when all was working. That doesn’t seem to matter.

Has anyone else experienced this problem?

Does anyone know where the partials get stored? Are they part of the project file or RW itself.

I am worried that if I make a website using partials and they have a habit of disappearing, that becomes a maintenance issue down the road. I can’t re-make all my dynamic content and fix all my pages every time I need to make a site update.

This is very perplexing. Partials seemed like just what the doctor ordered… but now I am not so sure.

I need help. (An yes, I have contacted YourHead support on the issue)


(Brad Halstead) #2

@thebugnut, are the Partials staying in the Site’s Partial Library item of Stacks 3 or disappearing from there?

It is a known issue that upon occasion after previewing a page or two and going back to edit mode the partial is not refreshed on the page. The work around is to go to a different page in edit mode and back to the original and all should bee good.

@isaiah is working on a fix.

Brad


(Peter Rood) #3

It is missing from my Library. I created around 6 additional partials yesterday and they were applied to 15 or so pages. Everything was working and saved. Today those partials are all gone, but the initial partials from two days before are still there.


(Brad Halstead) #4

@thebugnut, sorry, I have no idea why they are disappearing from your library or how to resolve.

Brad


(Peter Rood) #5

I may have to do some tests. I wonder if I need to re-instal Stacks 3. If I can find where the Partials are stored, I am look for them in my backups. Very frustrating.

Thanks for your help @Turtle


(Brad Halstead) #6

@thebugnut, I believe the Partials are contained in the Project file as they are project specific. I’ve safely used up to 6 Partials in a site, have not pushed it past that yet though…

Brad


(Peter Rood) #7

I have looked within the package contents of the project file, but I can’t see anything useful in there. They could be hidden.


(Peter Rood) #8

I just did a test and added a new partial to a project. I saved the file. Shut it down and re-opened it and the partial is gone.


(Peter Rood) #9

I just re-installed Stacks 3, restarted RW and I still can’t save any partials. I still only have the 4 original partials I created 2 days ago. Nothing from yesterday or today will save to the project file. I wonder if this is a problem with Stacks 3 or RW itself.


(Brad Halstead) #10

@thebugnut,

What version of RapidWeaver?

What version of Stacks?

What Theme are you using (Have you tried changing the Theme and seeing if it persists)?

What Version of OSX?

Where are you storing your project file (Local drive, remote drive, cloud drive)?

I cannot reproduce on with RW 6.3.6, Stacks 3.0.2, OSX 10.11.2, stored locally on desktop in a websites folder.

The more information you can give @isaiah at YourHead, the better for troubleshooting, he may want you to have a copy of the project file available for him to download from iCloud or dropbox or such for troubleshooting purposes.

I suggest you wait for his email, or update your ticket with what we have discussed and tried to assist him in troubleshooting. Christine and Isaiah do provide good tech support, sometimes just have to wait up to 24 hours.

HTH
Brad


(Isaiah Carew) #11

@thebugnut - partials work exactly the same way as other assets – like pictures – they’re stored inside the document that you use them in. also just like pictures, when you stop using them they are no longer stored anywhere.


(Isaiah Carew) #12

I should also note that there are some other helpful posts about partials here:

Hope this helps, feel free to post your own questions there too.

Isaiah


(Peter Rood) #13

Are the partials located somewhere within the projects file? If I examine the package content, should I be able to see them somewhere?

It seems my file must have been corrupted at some point early in this project, and no matter how many times I saved it, once I closed it I would lose all my newly created partials from the Library. I went into time machine and recovered the project file from Wednesday. I can create new partials and save them in that file. When I open I backup from Thursday or later, I can no longer save any partials in my library after that point. Everything else in the project seems fine.

So it looks like this issue is more of a RW bug of some sort. I am going to have to re-do all my work over the last two days and save move versions of the project in case of corruption. It is still strange, but I don’t know what else to do. I am going to have to make a completely new project file and copy anything I can use from the old file into the new one.


(Peter Rood) #14

And just so I understand the nature of the partials, if I create a partial and have it in my library, but I don’t currently have it on a page within the site, it will get deleted from the library after the project file is closed?

If this is the case, it is very strange. It makes it extremely difficult to use them to create stable templates. I can see how others would create a dedicated page to hold one instance of each partial just in case, so it doesn’t get automatically removed from the library during a large shuffle. Why can’t a partial just stay as a library item within the project unless I delete it?


(Robert Ziebol 🖖🏼) #15

My guess would be let’s say you make 30 partials, but only use 1, your project file will be bloated with 29 other partials that you do not need. Just a guess though.


(David Bailin) #16

I have the same problem with partials. Even within the same project, I’ll set up a rather complex stack and then use it during that session. Save and then resume the next day and it will be gone. What’s weird is that some of the partials will be still available but others not. Completely random and unreliable.


(Bruce Kieffer) #17

Just to be sure, are there “packed” instances of the disappearing partials on pages in your project? I’ve learned that if you unpack every instance of a partial, quit and reboot RW, those partials are gone.


(David Bailin) #18

Not quite sure I understand. I unpack the partial to use it, right? or are you saying that I shouldn’t unpack the partial at all when I place it on the page because by unpacking the partial that particular partial is removed from the partials window when I quit and open again? I thought partials would work like resources - unless I delete them from the partials project window they remain part of the resources of the project. I guess I’m missing something.


(Bruce Kieffer) #19

Partials work this way; If all instances of a partial are unpacked, then the partial will disappear after you quit and reboot RW. This is/was confusing to me and I had to lose a lot of partials before I understood what was happening.

The only reason to unpack a partial would be to change that instance of it, and not any other instance anywhere else on your page or in your project. Here’s a good example of a partial use: Create a text stack that says Copyright 2015. Create a partial of that stack. Place the partial in a whole mess of pages in your project, but do not unpack them. When 2016 arrives (very soon!), open the partial and change 2015 to 2016. That will change all placed instances of the partial in your project. Here’s another thread that discusses creating a library or stylesheet of partials in your project as a way to manage them.

One thing I stumbled on the other day was finding that you can modify an individual text stack partial to allow the text of that instance to be edited without affecting the other instances of that partial site-wide. Click the tiny pin (looks like a pin to me) icon at the upper right of the partial window to toggle the edit feature on and off. I’m not completely sure how this feature works, and I need to investigate it more. I still have much more to learn about partials.


(David Bailin) #20

That helps a lot. A Lot. But its not intuitive. A better naming device should be used. Current Unpack should be renamed to Placed. Then the function Unpack should be named Detach. Or something like that.