[solved] Portal-Stack throwing a Parse Error in RW8 with the Portal-Demo Project

After some fist try testing with the new Portal-Stack from @joeworkman, I could not get any results with a RW7 project. The content was not shown, simply blank, in preview. On the page with the portal-out stack, the content after the stack was missing as well.
So I tried the Portal Demo-Project with RW8. In this Project the portal in page showed a “parse error”:

Parse error : parse error in /private/var/folders/53/_gzqdk1j6vn5x_ksh_gxgq9rmd9zyx/T/com.realmacsoftware.rapidweaver8/RapidWeaver/5403/document-0x7fd403d31f40/RWDocumentPagePreview/rw_common/themes/Portal/portal.php on line 67

and the portal out page showed the normal content and a parse error as well:

Parse error : parse error in /private/var/folders/53/_gzqdk1j6vn5x_ksh_gxgq9rmd9zyx/T/com.realmacsoftware.rapidweaver8/RapidWeaver/5403/document-0x7fd403d31f40/RWDocumentPagePreview/rw_common/plugins/stacks/portal.php on line 67

On this portal out page, the footer is not visible (not even an error for that portal out stack). So this was somehow similar to my own project in RW7. Even when no parse error is shown in RW7.

Since I tried it with RW7 and RW8 (both fully patched and updated), and with even the demo project itself, I am a little puzzled what to do next. Maybe something was going wrong with the installation of the Portal stack? Is there a way to get more debug info?



I didn’t put it online, because it is not working in the preview of RapidWeaver8. The project is the Demo-Project from the Portal-Stack. So the Project-file inside the package you get, when you buy the stack.

I may be remembering this incorrectly, but I believe Portal does not work with preview. I believe that’s also stated at Joe’s website. (I may be remembering incorrectly. Going on my memory from about a month ago.)

Portal use php on the server to serve the content, publish the page (to a test area if need be) and I will bet it all starts working.

You are using RW7? What version of MacOS?

I tested this with RW7 with my own project file and with RW8 and your Demo-file. The MacOS-Version is Sierra 10.12. With the RW8 and the DemoFile, the mentioned errors are shown.

There is our problem. MacOS 10.12 runs PHP 5.6. Portal requires PHP 7.

Even if you installed PHP 7 on your Mac, I don’t think that there is a way to get RapidWeaver to use it. @dan or @tpbradley is there?

1 Like

Thanks, thats great to hear. So, problem found. Well, after hearing that, I tried some updating with my Mac. Now, PHP7 Version 7.3 is installed and PATH-Variable is set. Local Apache2 got the new LoadModule as well. Reboot,… aaaand… ?! Everything shows php7.3, but as you said… RW8 is not using it. I mean so it seems.
Well, not giving up yet. At least I know the source of the problem now. Again, thanks for that. So if there are any oder ideas, please let me know it. In the meantime I try some tweaking.

Ok, after some more try and error tests with my Mac, I can say the following. The PHP-Version 7.3 is installed now,… and used. PHP5 is not used anymore. The command “which php” points to the Version 7. But with RW8 the whole think does a crash-to-desktop. Well it was worth a try, but you where right. I think that means to go for High Sierra next. Thanks again for the info regarding the php-Version.


Why not using MAMP?

1 Like

Nice hint, thanks. But this one was for the system installed php version. The one used by RapidWeaver. So, in my case, even after installing the new version, RapidWeaver could not work with that. My local Apache, php & mySQL was working fine with the new php7.
Anyway, upgraded my system to High Sierra and this problem at least was solved. But now, after the update, my apache is making trouble. So, your suggestion comes perfectly at the right time! Thanks Jannis!

1 Like

Ok, update to High Sierra and everything is working fine with the portal stack in RW7 and RW8. Thanks again for the support @joeworkman. Case closed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.