*Solved* Post Office stack - layout question


(Adriano ) #1

Hello,

I am using RW7 - Foundation.

I am just about to set up my footer with the Post Office stack by Joe Workman and it looks nice, smooth layout.

I really like the GDPR consent box, but I’ll show you how it looks when I implement this feature in the stack:

There seems no way to get the consent message next to the check box…I think it would look better that way. There should be a way, right?.

The settings for custom sizing do not include the GDPR consent message and box

Any support with this is highly appreciated.


(scott williams) #2

It’s going to be pretty difficult to help with this one without a url so we can see what is happening.


(Adriano ) #3

Hello Scott,

thanks for your message.

Okay, this is the link of an invisible page in my site.
The page is completely blank (except the menù bar and footer) and that is why the footer is at the top, but I am sure you get the idea from it.
I just do not want to publish it in other pages, until the Post Office stack is ready, looking good and set up with my newsletter service provider!.

Basically I wonder if it is possible to put the text regarding the GDPR NEXT to the box related to it.

https://www.healingdietcoach.com/events/

Cheers


(scott williams) #4

it’s because there is a 1rem right margin set on the label element and the check box it’s self is set to float-left which takes it out of the document flow.
I don’t have that stack so I have no clue what the built in options are.
Did you add some CSS to the page?


(NeilUK) #5

Maybe @joeworkman could help with this?


(Joe Workman) #6


(Adriano ) #7

Hi Scott,

thanks for looking into it.

Yes, that’s interesting. Probably that’s is its default settings (!?). I didn’t add any CSS to the page.

I can see from the screenshot that you have managed to put the consent statement next to the check box. How did you do that?


(Adriano ) #8

Hello Joe,

thanks for helping out.

I tried that, but as you can see nothing changes, except that now the message is on the top.


(klaatu) #9

try using this CSS:

.field.gdpr {

display: flex !important;

}

(Adriano ) #10

Hello Klaatu,

Wow ! :slight_smile: That’s awesome. I have no idea how it works, but it works!!!.

Thank you for the tip and suggestion!!.


(klaatu) #11

My pleasure sir!


(Joe Workman) #12

Sorry for my delay. Looks like Klamath sorted you out. The theme must have some styles that cause hte checkbox and label to be on new lines.

I do think that the checkbox will look much better on top of the form. Or else turn off inline forms.