The document could not be opened - Contents.plist?

It says that file/Pages/1-003Ci-class003D003C00Fi003E/Data/Contens.plist´file does not exist…I have an older version which opens without problem?

Some solution?

Same here - "Contents plist does not exist."
About a week ago I tried to restore a project file from Time Machine. I got a “file does not exist” error with “Contents.plist” - (still do) I had alternative backup so I didn’t even look into the issue. Guess I better dig into it more.

UPDATE
In my case the plist is there and appears to be a valid when compared to the current working project.

The the OP, jhelstad1971, if you right click on the project file and “Show Package Contents” it will show you the contents of the project (files that makeup the one sandwich file). Verify a Contents plist is there. You can open it with a plain text editor and view it. Should be readable xml. See if it’s there and reply. (work on a copy of your project)

UPDATE
The Time Machine RW project file does NOT include these files that are in the current working project:

  • Resources folder
  • RWUIState.plist
  • SharedPluginData folder

The error msg is not saying the plist is missing… it’s saying that a file that plist is referencing is missing.

This means any RW project from Time Machine is not going to work? When did this happen? I admit that it’s been a long time since I’ve restored a project from TM but I didn’t know the Project Sandwich files were not valid.

To OP, jhelstad1971: Is your “bad” project file coming from a backup or cloud?

@jhelstad1971 and @1611mac : About 2 years ago I started backing up in a fourth way:

  1. Super Duper
  2. RW’s own backup
  3. Time Machine
  4. zipping my own project file

I started this 4th way because of some reports like you two have made (and other reasons). I also archive my project names (e.g. Project1-2020-01.rw). Typically I name based on month, sometimes during heavy development more often. And obviously if it is an old project then I have a small series of “archived” named projects based on the last year/month I worked on a project. This can all help because … you have more backups!

But for me the key were steps 2 and 4. If you have been taking advantage of RW’s internal ability to back up to your server then you should be in good shape. That back up has been zipped and thus protected from events like you just experienced.

Step 4 is much newer but I’ve done it because I’m not 100% sure how well my computer, or iCloud, or Dropbox will all handle a standalone RW project. So zipping helps tremendously.

Okay … I realize this is mainly bad news, but perhaps some tools to use for the future. But hopefully you have both been taking advantage of RW’s backup feature and can download your latest backup from your server. It should not have the problems you’ve described.

As for why it happened? I have no idea, but it’s simple to be proactive in the future. And the two of you have hardly been the only ones to have an experience like this. It’s not that this happens frequently, but it does seem to happen in certain situations. I see the original poster was using Dropbox … so that may be part of the issue.

Mathew… I agree with all you say and I have plenty of backup. (Can’t speak for the OP.) Thanks for the reply. This is not about backing up. I have backups to backups to backups. This is about the issue that I’m finding out for the first time that Time Machine backups of RW project files are not good. Is this known by the community? Perhaps I’ve been asleep at the wheel on this one?

Also, we don’t know yet the source of the OP files and from where they come. I just don’t want the thread to be turned into a “backup” thread. - Thanks for your reply.

Still waiting on reply from OP. (about the source of his files - if Backup or Cloud)

Tagging @dan to see if they have reports of non-functioning RW TimeMachine backups or what they might suggest…

@1611mac Based on the original screenshot provided it seems the RW project was stored on Dropbox. There have been a few reports of wonky behavior on Dropbox. Time Machine: I haven’t heard anything about project files going bad.

Ah… good point Mathew. I didn’t look good enough. Yes, I’ve said for while now that RW Project files don’t play nice with Dropbox. I zip my DropBox copies. Evidently Time Machine copies will need to be zipped also. I also have web server copies, which I do myself, pocket disk backups, and Carbon Copy Clone bootable’s with the RW files. I think most who don’t know will trust Time Machine… if if TM projects are bad… well, there are going to be unhappy people when they need their backups.

I’ll try to test some of my Time Machine backups in the next couple of days. Yes, it would be pretty scary if Time Machine does something similar to Dropbox!

From experience RapidWeaver project files stored in Time Machine work just fine. It sounds like you just got unlucky. I personally wouldn’t just rely on TimeMachine, I’ve heard some real horror stories where people can’t restore anything from a TM.

RapidWeaver’s built-in FTP back-up feature does a good job. This has saved a lot of peoples lost or stolen project files. If anyone is reading this and hasn’t got it switched on, do it now!

I would also recommend using a local TM backup along with Backblaze an online backup service.

Sorry I can’t be of more help.

1 Like

I’ve now tried opening several Time Machine backups. Some work, some don’t. Of the one’s that don’t there are missing files in the “Sandwich” project file. Also, I instructed Time Machine to restore a folder which contains 11 RW project files. Only the two that were changed since the previous TM backup were restored. In other words, it didn’t restore the folder, it restored only the changed files.

Given a FOLDER name of “RW Projects” I renamed my good production folder to “RW Projects PROD” - Thus I no longer had a “RW Projects” folder. I then restored “RW Projects” folder from TM. It only restored the two projects changed since last time even though the other projects no longer existed. So given a folder to restore, it is not restoring the folder with all contents. It’s restoring only the files that have been changed in the folder being restored. Likewise, if all files in a project Sandwich are not changed, only the changed files are restored, not the complete Sandwich set.

I honestly never realized this. I seldom use Time Machine to actually restore, and when I do it’s seems it’s always been a single file, not a folder. Perhaps the knowledge that TM restore works strictly at the file level and not the folder level is common knowledge. But I honestly never thought about that.

1 Like

I restored a project from Time Machine once only to get the plist error. Various items in the folder content were missing. I then tracked down the project in the TM archive and dragged it out. It was complete with nothing missing. This gels with @1611mac issue restoring folders.