Total CSM Blog Failure to Preview in Rapidweaver or Publish


(Casel Melendy) #1

My Rapidweaver website is not communicating with Total CMS. I cannot preview a blog form, blog or blog post page within Rapidweaver.

THE MESSAGE that I get is this: Could not communicate with Total CMS. Either you have not published your project yet, or your website address is not properly set. Click to ingore

Given that my Total CSM says it is registered, and I am able to publish my website and get a ‘non-functioning’ blog page on my website that lists blogs that won’t open in their own page…it seems clear to me that the problem is WITHIN the relationship between Total CMS and Rapidweaver.

This brings us to ‘your website address is not properly set’ - however all of the settings are correct (I do have a path of public_html and it is a PHP website…could that be the problem?

My Rapidweaver version is Version 7.5.2 (18795)

In Rapidweaver, I go to my Admin Page in Preview mode. I click on New Post. I am redirected to my New Post Admin page. I get this message ‘Could not communicate with Total CMS. Either you have not published your project yet, or your website address is not properly set. Click to ignore.’ I enter content to the blog form. I hit ‘Save’ - I get only RED X’s. I do NOT get a preview of my blog there or on my Blog page.

I am now running the latest version of PHP and if I go to my ONLINE admin page, click on New Post, add content in the ONLINE blog form, hit Save… I am redirected to my Admin blog list and the new post DOES appear in the list. If I click the new post from the list, I am redirected to the post and it opens to the post and the URL looks like this https://herenowhealing dot com/blog-post/?permalink=new-post

BUT if I go to the blog page herenowhealing dot com/blog/ and click on the blog, it opens to a new window where it says ‘Not Found - The requested URL /blog/new-post was not found on this server.’ and the URL looks like this https://herenowhealing dot com/blog/new-post

I have watched this video several times and followed the steps (Joe Workman Total CMS pt5 - it won’t let me put the link)
I have watched the video Robert at RealMac made for me several times and followed the steps
I have watched all of the other Total CSM videos made by Joe Workman.

I have remade my blog and admin pages from scratch multiple times and only get the same results. I am now at over 140 hours into trying to make a blog on my Rapidweaver-Foundation-TotalCMS website.

I can’t be the first person that this has happened to. I built the website in Rapidweaver using Foundation. The ONLY Total CSM pages are the four blog related pages (Admin, Blog Form, Blog List and Blog Post)

What do you think the problem is?

Any help you can give would be much appreciated.

Best wishes, Casel


(Robert Ziebol 🖖🏼) #2

Have you previewed the Blog Post page and submitted the URL??


(Casel Melendy) #3

Hello Robert,

That’s the thing…I can’t preview the Blog Post page, so I can’t submit the URL

In Rapidweaver it won’t preview when I hit save on the Blog Form page…just red X’s

If I go to the online Admin and create a new post, it will be listed on the blog list, and when I click on the blog on the blog list, it will open to the blog post BUT when I go to the blog page and click on the blog post (on the blog list) then I get a 404 message.

Thanks for your help and any thoughts on this would be appreciated.

Best wishes,
Casel


(Casel Melendy) #4

Hello Robert,

That’s the thing…I can’t preview the Blog Post page, so I can’t submit the URL

In Rapidweaver it won’t preview when I hit save on the Blog Form page…just red X’s

If I go to the online Admin and create a new post, it will be listed on the blog list, and when I click on the blog on the blog list, it will open to the blog post BUT when I go to the blog page and click on the blog post (on the blog list) then I get a 404 message.

Thanks for your help and any thoughts on this would be appreciated.

Best wishes,
Casel


(Robert Ziebol 🖖🏼) #5

I am not talking about saving on the blog form page. Even if you have NO content, you should be able to preview. You want to look for this setting in the Blog Post settings:
46%20AM
What do you have the Post URL set to?? It almost sounds like you have it set to pretty. If you do, turn it back to default (lets get the blog working first, then try to set up pretty URLs). Once you turn it back to the default, you should see this lightbox appear (it will look a little different, but most of it will be the same):

As long as you have published the CMS to your site (what is the URL by the way??) you should be able to preview it in RapidWeaver and get the lightbox to appear any time you change those four settings in the Post URL.


(Joe Workman) #6

I have been helping out over here… https://community.weavers.space/s/cms-rapidweaver/?contentId=82720


(system) #7

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.