Total CMS preview issue


(Tim Lawson) #1

Very odd behaviour going on… opened a project for the first time in a while today, and the first time since updating to RW v. 7.5.1 and macOS 10.13. The project contains a licensed version of Total CMS - the Blog Post page is a sub-page of the Home page. You can see the website here.

When I go to preview either the home page or the blog post page, I get a whole mass of code instead of what I’m expecting - see the attached from the home page - (sorry, necessarily an image as .rtf files not allowed here.)

.

I’m reasonably sure that the issue is caused by Total CMS as all other pages in the project preview as expected.

Help please! ? @joeworkman @zeebe

TIA,
Tim. (I’m in UK so my replies may be delayed)


(Joe Workman) #2

Is your page set to be PHP?


(Tim Lawson) #3

Yes, all pages in the project are :slight_smile: This project has been up and running for quite a while now - not seen this issue when trying to preview before though. I wonder if it’s consequent on Total CMS having been updated?


(Joe Workman) #4

Restart RapidWeaver? What have you changed since it was working?


(Tim Lawson) #5

I’ve restarted RW a few times - sadly it makes no difference. The only things I’ve changed are on other, unrelated pages in the project.

To qualify that, Joe, I’ve removed Pagesafe from another page and updated some other stacks, but nothing on either the home or blog pages.


(Tim Lawson) #6

Would you like me to send you over a cut-down version of the project, @joeworkman - just the offending pages perhaps?


(Joe Workman) #7

that works for me…


(Tim Lawson) #8

It’s here, @joeworkman - thanks in advance for looking at it.


(Joe Workman) #9

what page is it? I can’t find it… The home page works for me… Granted, I am using the latest Total CMS beta though.


(Tim Lawson) #10

For me it’s the home page and the single sub-page - ‘blog post’ I think (left my desk now). Great that it’s working in the new beta though

When’s the new TCMS version going gold?


(Tim Lawson) #11

Hi @joeworkman… OK… I’ve downloaded the TCMS RC3 and republished all files from RW.

Everything is still - and was previously - working on the website BUT the issue I’ve been describing was and still is entirely to do with Preview in RW - that’s where I see all the "gobbledegook’ that I took my screenshot of.

I see, when I scroll down all the nonsense in the RW Preview pane, that there seems to be a video. Could that be the issue - has someone tried to add a video to the blog and that’s perhaps caused / causing the glitch?


(Joe Workman) #12

I released RC5 last night. I assume that you got that since the downloads for all of the previous betas are gone.

Could you take a screenshot of RapidWeaver for me?

Try to duplicate the page and start removing things from the page until we find the culprit. You dont have anything inside the page inspector tabs that could be causing an issue?


(Jason Bostick) #13

FYI, there’s a release candidate 5 available. And it looks like the final release should be out tomorrow (the link is the comments on the post here: https://weavers.space/content/perma?id=68790)


(Tim Lawson) #14

@jabostick - thanks - yes - it must have been RC5 I downloaded - sorry - I thought I had read it was RC3.

@joeworkman - Screen shots attached - apologies for size. I wonder… have things changed to such an extent in TCMS that I need to completely overhaul the project? For example, the ‘Layout’ and ‘Read More’ stacks seem to have gone?

If this is the case, I need to do a lot of reading to catch up - can you please let me have a link to where I can grab a tutorial or similar?

Did you open the project file I linked you to, @joeworkman, to see if the above is indeed correct?

TIA,
Tim.


(Joe Workman) #15

Your project looks like its setup properly. And it works on my machine just fine. Could you send a screenshot of preview? (that was what I really wanted before, sorry for not clarifying)


(Tim Lawson) #16

Well, that’s good news at least. The 7 screen shots below are what I see in Preview mode as I scroll down. Intriguingly, I note that there’s a Twitter entry (5th and 6th shots) that’s not evident online but removing the HTML stack that is the Twitter feed achieves nothing.


(Tim Lawson) #17

Shots have landed out of order - want me to re-send, @joeworkman?


(Joe Workman) #18

What version of MacOS are you running? Did Total CMS every work?

Did you try to trash the Total CMS stack from within Finder? then manually install it?


(Tim Lawson) #19

10.13 Yes - TCMS worked perfectly before I upgraded to 10.13. No - I haven’t deleted anything to do with TCMS ever in any way!

They all seem to be there:


(Tim Lawson) #20

Hi @joeworkman

I have tried to have a really thorough look at the cut-down version of the project I sent you and having replaced the only stack showing as “Legacy” (‘Blog List’ on the home page) with the new ‘Blog List’ stack which unfortunately makes no difference to the Preview in RW7.5.1. I have also checked exactly which stacks I have installed for TCMS and have separated them into two groups in RW so as to easily be able to send you screen shots of them (below). I don’t know if any of this will help diagnose the issue but I’ll do anything I can. Your help is very much appreciated.

TIA,
Tim