User Library .plist files


(Ron Belisle) #1

I’m looking in my user library and not noticing Rapidweaver .plist files. I’m having strange behavior with Rapidweaver and would like to delete the .plist files. That has worked before. The strange behavior has to do with my Media Browser not showing photos but only videos. I’ve written Rapidweaver support several times and they seem to have given up on me. I’ve also posted the issue in this form, but no help has responded.

How can I delete Rapidweaver .plist preferences?


(Ron Belisle) #2

Can someone answer this question for me? How can I delete Rapidweaver .plist preferences? I’ve had serious issues for many months with my Media Browser not working since upgrading to Rapidweaver 7.


(Isaiah Carew) #3

The simple answer is: yes, but it may not have the desired effect and will likely have several undesirable side effects – but nothing too catastrophic.

it may not have the desired effect

since macOS 10.11 (i think) the user preferences are cached in memory by a system process. this means that simply deleting the file will not necessarily have any effect – the system may try to rewrite the file with the old prefs (or may not – it’s kind of a crapshoot).
the recommended way to do this sort of thing now (ok, it’s always been the recommended way – it’s just now the only surefire way) is to use the defaults command. in Terminal you use defaults delete and it will wipe away a specific default.
there are other ways of nuking the whole file, but i’m not an expert there. Google will have to be your friend.

it may have side effects

clearing all the rapid weaver defaults will obviously clear away all your settings and preferences. it will also remove some serial numbers – so you’ll need to reregister addons like Stacks.

You may want to, instead, contact Realmac support for assistance into fixing the problem at hand, perhaps that have a way to just reset this single preference.

Isaiah


(Ron Belisle) #4

Hi Isaiah, Thanks for the info. I’ve tried to contact Realmac support for the last 6 months on this issue. There was some initial response, but the problem never was resolved and they never followed up on it. I’ve posted on this forum 2-3 times and still not getting anywhere. Here’s the link of one of the posts.

This has been a pain because anytime I want to work with photos in Rapidweaver, I can’t use the Media Browser. I have to go to Photos, download what I want and them import the downloaded photos in my Rapidweaver project. It’s a hassle.


(Isaiah Carew) #5

I can’t help with the specific Media Browser problems. That’s probably a technical enough detail to require assistance directly from Realmac. Even though you’ve had trouble with it in the past, I’d still recommend trying to contact them directly.

As for defaults: You can run a test to see what deleting all the prefs will do to help you decide whether it’s what you really want to do.

Create a brand new user account on your computer (just temporarily, you can delete after you test) and launch RapidWeaver in that temporary account. That new account will not have access to your current settings – it will be as if you deleted all your preferences.

If that works, and you don’t mind the hassles (re-entering serials), then perhaps deleting the prefs would be the way to go. Just know that it’s kind of the “nuclear option”.

By the way, the different versions of RapidWeaver store their prefs in different places, make sure to nuke the right one. For most users – RapidWeaver 7 downloaded and installed from the Realmac site – it’s located here:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Preferences/com.realmacsoftware.rapidweaver.plist 

I’d recommend:

  1. reboot
  2. delete that file
  3. reboot
  4. double check to make sure the file was not re-written by macOS
  5. launch RW

or, conversely if you feel confident in Terminal the unix command is:

% defaults delete com.realmacsoftware.rapidweaver.plist