8.1.1 can't save on desktop

i want to save my Site to my desktop, then I choose File>Export Site, then New Folder, then I type, as usual, a name and create, then export and I get this message:
“The publishing destination is incorrectly configured-please update the publishing destination settings and try again”, and after enter I get the Publishing page… but WHY?
I want to do this operation as usual manually and now I’m stuck
p.s. I tried to edit the publishing page chosing a local folder too, but no result… :frowning:

I’ve just tested both on my version of 8.1, both times it worked.

I did the steps you described above. I named a folder “test folder” on my desktop and exported the site. I also tried publishing to a local folder and that worked too.

Have you tried installing 8.1 again? If you do, make backups of important files etc.

You could also send your project my way if you’d like me to test it for you. If you do, message me and I’ll give you my email address. If not, I’m not sure what else you can try. It’s not a fault with 8.1 in general because it works flawlessly at my end.

You could contact Realmac directly to see what they can do.

1 Like

thanks Neil for your prompter answer.
mmmm How can I install 8.1 again? I did the upgrade inside Rapidweaver 8.03 and now I can’t.
Sending a complete library is little bit a problem due to all the attachments.
I have another issue and I will open another topic…

You can get any RapidWeaver release here:

1 Like

I think that the RW’s behavior you described is due to the new “feature” – sandboxing. Once you do what RW asks you to, there will be no more prompts to enter a destination info. At least, that’s my interpretation…

I reload a new 8.1 > negative, still saving on desktop does’t work.
I reload 8.03 > it works fine

Here’s an option if you want to have both versions available:

I work normally with a lot of backups, I can get it right back with RW 8.03; I lost only one day of work working on 8.1 :frowning:
but I’m asking me if this will be a problem that will be solved with the next versions?

Updated to 8.1.1 > no change. Can’t save on desktop.

I did the same test as @NeilUK and am Not having issues at all saving or publishing to the desktop. Perhaps you could give us a screenshot of what message you are getting?

  • I can choose export from the file menu and choose (or create a folder) on the desktop and it works Fine
  • I can under publishing settings choose “Local Folder” select a folder on the desktop and it publishes without a problem.

I can also save my project file to the desktop.

Perhaps We are misunderstanding what steps you are doing, and what error you are getting.

here the sequence:
a- I open my application with RW 8.1.1 and I’m in edit mode
b- I choose File>Export Site
c- I get a window of the contents of my hard disk and I can choose a New Folder (the button on the left side) or an empty folder (named: “rex”, for instance) or directly Export button. In fact I have four choices.
1-I choose “New Folder” > I name this folder “Happy” then Export button (on the right) and I get the message:
“The publishing destination is incorrectly configured-pleas update yhe publishing destination settings and try again” (cancel or Update settings) and… with this message the application is stuck. I have to force quit.
2-On point 1 instead choosing “new folder” I can choose a previous configured “rex” folder (Publishing page) and directly “export” button > then the same results as before “The publishing destination is incorrectly configured-pleas update yhe publishing destination settings and try again” (cancel or Update settings) but the application is not stuck.
3-On point 1 instead chosing the previous choises, I click once on my “rex” folder and “export” button >
result: same as the last attempt.
4-On point 1 instead chosing the previous choises, I click twice on my “rex” folder and “export” button >
result: same as the last attempt.

I’m not seeing that at all.
Have you tried with a different project?
I can select the folder or create new and have no problem.

There must be something specific to your project or something.

This might be one to get a project file to @tpbradley at RealMac.

thanks Doug,
I tried with another project and it’s the same story: same error: “The publishing destination is incorrectly configured…”
Good idea to send my project to @tpbradley: I will ask him

Hey guys, I think I’ve found the source of this problem.

When you export your site, RW is checking to see your chosen publishing destination is correctly configured. This is definitely a bug, I’ll get a fix into the next update.

While you’re waiting for the next update, make sure you have at least one correctly configured publishing destination. You should then be able to export your site again.


good news here!
as Tom Bradley suggest, I have configured the “Publishing” page inside RW 8.1.1 and I could save my project to my desktop.
Thanks Tom!

1 Like

Hey guys, RapidWeaver 8.1.2 is available with a fix that should solve this problem! Please update and give it a go.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.