Rapid weaver Version 8.1 (20579)

Just installed the Version 8.1 (20579) update and now cannot save or publish my sites has anyone had the same problems ?

Can you restart your Mac and try again?

Same problem after installing this version.
notification 1: This document uses files in multiple locations that RapidWeaver is unable to access

No idea what i have to do. When i choose " Not Now" then next notification appears:

notification 2: NSUnknownKeyException

Can’t open anything anymore :frowning:

Please help !

Same issue with the ‘This document uses files in multiple locations that RapidWeaver is unable to access’ but I don’t get an error message when I choose ‘Not Now’.

I tried choosing where my RW 8 addons and stacks are, but still get the same ‘muliple location’ pop-up.

The site seems to be OK when I preview it, but I haven’t been through every page.

Browse from Publish works OK, so FTP publishing should be OK.

This document uses files in multiple locations that RapidWeaver is unable to access
This is a new feature that prevents documents from losing images, resources, etc, when you move the file to a different Mac, etc.

Select “choose” to navigate to the directory where your RapidWeaver images and assets are located, then save your project file. Quite and re-open when completed.

If you don’t have all your images in one place, which is likely, then we’d suggest putting all assets in one folder with your RapidWeaver project file. This is just good practice.

Make sure all of your plugins are up to date. Sometimes plugins don’t have auto-updates enabled, so you’ll need to manually update.

I just installed 8.1 and can save and publish. My setup/installation is straightforward with RapidWeaver in the applications folder and the projects folder on the main drive which is generally the most reliable organization.

Can you use Time Machine to return to pre-8.1 ?
That is always the easiest solution.

You can revert to previous versions here:

We recommend against this, especially if your project file has been opened in a newer version. Use at your risk.

1 Like

Hi Jan restart did not help and other thoughts?

Has the name of your Hard Disk any special characters like a ’ or similar? Then you could rename your hard disk and try again…

I make extensive use of warehoused images and files using Cloudinary. Could this be what is confusing RW 8.1 with the multiple file warning?

If so, presumably I can just ignore the warning. Seems like overkill to me? Any way of turning this warning off?

Time Machine used correctly can restore to the prior working status, that is my suggestion. Just reverting to the previous RW version is not what I suggested. It is worth looking into for anyone facing these problems seeking an immediate solution.

Just seen this post. Yes 8.1 messed up my machine as well. Trying to get back to previous version.
I had same error. I use dropbox for storing resources and am wondering if that is the issue with 8.1…?

cannot save. cannot preview

I have many images all sorted by type, place and use. there is no good reason to put all these into one folder that would make loading the right image near impossible. this would unnecessarily complicate my workflow.

1 Like

same problem(s) here.

I wasn’t replying to you originally, but do appreciate your input! Agree… :slight_smile:

1 Like

Complete dog’s breakfast. Even reverting to 8.03 and using a version of my site last uploaded with 8.03, while everything is there I cannot now add pictures to new blog entries. tried creating a new site with 8.03 and the same thing happens. Just will not accept images.

OK, sorted out this problem:

This document uses files in multiple locations that RapidWeaver is unable to access

Two of my four websites gave the multiple location warning on load. I chased this down by duplicating my project and then using the copy deleted a page at a time until the error went away on reloading. Both projects I ended up deleting EVERY page (adding a dummy blank page so I could actually see the project) and still I was getting the warning on load.

I checked the Resources and saw on one project that one of the two resources was showing a cross as ‘unlinked’. Tried relinking this by right-clicking and locating the image file in the folder on the Mac. Saved and reloaded the project, same warning message. Deleted the resource and dragging the image into resources, saved and reloaded - the warning message has gone, problem solved.

The other project was a bit more difficult. Deleted EVERY page (adding a new blank page) deleted the resources, web logo and the web icon images, in fact EVERYTHING in the project except for the one blank page. Still got the warning after saving and reloading.

Created a new 8.1 RW project and dragged and dropped every page from the old project into the new. Added web icon images and site logo and updated the General setting and publishing details. Saved and reloaded the new project - all good, no multiple location warning.

I have decided to just rebuild my sites can’t wait around for Rapidweaver to rectify.

Hmm I’m going to try that. A