Export problems with RapidWeaver 8X

I have been using RapidWeaver for years and never had any issues. However, after RapidWeaver 8 (I am now at Version 8.5.1) I started having issues with either exporting or publishing my site, to either my server or to my desk top! I get this message that states “unable to export”. Strangely, by trial and error (more error and far more trials than I care to recount) I discovered that if I generate previews of every page in my site (http://www.iclm.ucla.edu) and then save and shut down the program, I can sometimes export the site. This means that with every small update I spend 10-20 min trying to export the site… Please help?


Im having the same issue! Was hoping someone here could help …

Are you using Nick Gates Depth style?

Yes …

Im not very techy, having taught myself the basics only - Im an artist and potter! However, I decided I really had to get my head around it and proceeded to update my website completely with new blog … then damn … I just can’t get it to export . I’ve contacted mac dock for help but haven’t heard back from them yet.

You could try what I tried and “worked”. It is a pain and no more than a temporary fix but it will work if you have the patience… Place your web file in preview mode and preview slowly every page of the site. Then save and close the web file and place it back in preview mode and try to publish or export. If that does not work, repeat what I just described and try again to publish or export. I have used this cumbersome method many times and it works every time. The problem is that this is a true pain in the neck! Hope this works as a temporary fix and most of all I hope Rapidweaver gives us a fix for this annoying problem!

1 Like

Thank you, I will try that … Im also waiting for Macdock to get back to me in case its a hosting issue. All very tedious indeed!

You are both using the same theme and have the same publishing problems? I don’t suppose you have tried another theme?

Not yet. I’m still waiting for Macdock to get back to me. I’m going to see what they say before I waste any more time pressing buttons and getting frustrated​:face_with_monocle: :laughing::exploding_head:

Hi All

I also recently did a major update on my website and I am having the exact same issues. In my case I am using Nick Cates ‘Aspen’ theme. Deeply frustrating

Yes. I have gone through the web file and changed every page to a rapid weaver theme and still had the same problems…

To test whether it is a hosting issue you can try to export the web site to your desk top… I suspect it is not… I have the same problems when I try to export to my desktop. When I can do one (export to the desktop) I can also do the other (publish the web site)…

it seems that the common thread is Nick Cates and of course RapidWeaver… I have tried to make a dummy web site with a RapidWeaver theme and I did not have the issue… However the dummy web site had far fewer pages, graphics, and in general was far less complex than my actual web site… It would take too long to actual redo my web site from scratch in an appropriate RapidWeaver theme…

Hi Alcino

Firstly thanks for your interest. Your comment re uploading a smaller site is valid, as if I upload the earlier pre-updated website it publishes, although there is only about 20mb in file size between the old and new versions.

I have been in touch with Nick Cates and he seemed to think that the problem was a Stacks issue and nothing to do with the theme.

I am awaiting a reply from RW themselves.

1 Like

Both of the web sites that I designed have stacks… Strangely, as I said, if I preview each of the pages, invariably at the first, second or third try after previewing, saving and reopening, the web sites finally exports and /or publish. If it does not export it will not publish and vice versa.

You are right - it won’t export to desktop either. Arghhhh Im so stuck I don’t know what to do . …gnashing teeth and weeping!!

When you export to a desktop folder, do you get an error message? If so what is it? What OS are you running? Do you have any 3rd party add-ons installed? Are they all up to date? Check the developers’ sites to be sure.

Try this: create a new project, and with the new and problem projects open, drag a page from the problem project to the new project. I think you need to add a page to the new project first, so you get the list of pages where you can then drop the page. Once you get a page from the problem project, you can delete the initial page you added from the new project. Can you export that new project to the desktop?

No it just says unable to export … does not tell why. I will check all the add ons (I don’t have many). Will do all that you suggest as soon as I can find time … one of the annoying things about this is I have work to do (LOL) and its so damn time consuming.

I have OS 10 Mojave

Update for everyone - we’re working with Susannah and have it isolated to a plugin/filename issue. If you’re having the same issue, please email us support@realmacsoftware.com with some support logs

  1. Go to RapidWeaver > Preferences > Publishing and make sure “Upload Logging” is enabled

  2. Now, try publishing / recreating the issue again

  3. Finally, go to Help > Copy Support Logs and paste this into a document, and send it over in a TextEdit document