About publishing a link to your site


(Peter Kroman) #1

Hi,

When I post a link to my site in one of our Facebook groups, it comes up like shown in the picture - Example Domain and so on.

Anybody who knows why that is? And why it doesn’t make kind of a “guide-picture” to go with the link like many other sites does?

The link to the site is here: http://peterkroman.dk/Peter_Kroman_familie_hjemmeside/

(Now fully migrated form iWeb to RW 6 :slight_smile: )


When Facebook links to my site it's picking up the wrong logo, why?
(Nik Fletcher) #2

This is because you’re using a stack that includes some example metadata…

<meta property="og:type" content="website"/>
<meta property="og:title" content="My Site Title"/>
<meta property="og:image" content="http://example.com/myimage.jpg"/>
<meta property="og:url" content="http://example.com"/>
<meta property="og:description" content="Insert description here"/>
<meta property="og:site_name" content="My Site Name"/>
<meta property="fb:admins" content="fb_username"/> 

If you update this copy in the appropriate stack it’ll be corrected, though you may need to enter the URL here: https://developers.facebook.com/tools/debug/ and then choose “Fetch New Scrape Information” to get the metadata to be reflected in future Face
book posts.


(Peter Kroman) #3

Thanks @nikf

Well - I’m afraid that I need further help to do this. I am an absolute beginner with code, so I need to be guided to:

  1. How do I define which stack to update
  2. How and where do I put the code lines you supplied in the stack

Thanks in advance


(Andrew Tavernor) #4

@peterkroman This is the Foundation SEO helper stack that you have added to your page but not filled in any of the required fields. Simply enter your appropriate information in the settings and republish.


#5

@peterkroman I agree with the previous comments. For best results with Facebook make your image 1200x627 pixels. I found it easiest to host images for Facebook and Twitter etc in a specific folder and you will need to ensure that hotlinking is not blocked on that folder otherwise no image will appear.


(Peter Kroman) #6

Yes, I have added the SEO helper to my pages. I have integrated it into a partial I use for my page header. But I don’t seem to get the possibility to fill in any fields in the SEO helper when I try to edit the partial. What am I doing wrong :slight_smile:


(Brad Halstead) #7

@peterkroman

Everything is good in that screenshot EXCEPT you have the SEO Helper stack hidden, unhide it and you will see a + button and by default, when adding the stack, it has Facebook open graph data in there…

Brad


(Peter Kroman) #8

Thanks @Turtle

That helped.

I have now edited the settings of the SEO helper, but after editing and republishing I still get the same “Example Domain” thing when I publish a link to FB.

Here is what I have put in the settings:


(Andrew Tavernor) #9

Your page has been updated with your info but you are still looking at the old .html file.
Adding SEO helper will change your page to index.php. All you need to do is FTP into your server and delete index.html from the root - just leaving index.php

Here is your open graph data from http://peterkroman.dk/Peter_Kroman_familie_hjemmeside/index.php


(Brad Halstead) #10

@peterkroman, what @tav said and please, no special characters or spaces in filenames… can cause all kinds of random issues…

Brad


#11

@Tav I believe Foundation 1.6 will solve that problem by warning users they have a PHP and Html page on the server. https://plus.google.com/+JoeWorkman/posts/FofiLBWGyFe


(Andrew Tavernor) #12

Indeed it will but this is a key skill that users need to know how to handle manually as well. If things do not appear as expected after a publish the first thing to try is manually entering your url ending in .php and see if the correct page is present there.


(Peter Kroman) #13

Thanks @tav

But there is not an index.html file on my site.

Here is the root of the site:


(Peter Kroman) #14

I have also been through all the sites sub-folders, and I don’t find any index.html files at all :slight_smile:


(Andrew Tavernor) #15

In that case every thing is OK. The meta data screenshot above was from your published site so I’m sure it is just a case of waiting for Google to re-index your new content.

As @Turtle says though - get rid of those space in the image links and also update the site name so that it no longer says “My Site Name”.


(Doug Bennett) #16

Did you follow what @nikf said and On face book:

I have changed images and it can take a couple of days to show up with the new image. I didn’t know you could force the update like this. Good to know.


(Peter Kroman) #17

Well, Scraping and entering correct fb-username and a proper Site Title helped a little.

But I still get an error when fetching new scrape information and it will still display the same “Example Domain …” as it shows.

It says that I need to add a fb:app_id to the metatags.

What is that, and how do I do it :slight_smile:


(Nik Fletcher) #18

Try forcing another re-scrape. The bit at the bottom is heavily cached, and takes a few force refreshes to appear.


(Peter Kroman) #19

I have tried re-scraping 20-30 times now. Still the same.

Not other error messages than the one with the fb:app_id.

What to do?