When Facebook links to my site it's picking up the wrong logo, why?


(Gabrielle Vickery) #1

My site is here: www.stormdesignprint.com

I have used a site logo, web clip and favicon in the general settings.

Yet in Facebook if someone posts a link to my site, it’s picking up the Linkedin logo image that is on my home page.

Why IS that?

Gabrielle


(Jannis from inStacks Software) #2

Maybe because the logo is a background image, and Twitter a “real” Image tag?


(Richard Nicholls) #3

It’s because you don’t have any facebook open graph meta info in your header.
You need to reference a specific image with

<meta property="og:image" content="http://www.stormdesignprint.com/your-image.jpg" /> 
<meta property="og:image:width" content="685" />
<meta property="og:image:height" content="386" />

Once you’ve done that though, you’ll need Facebook to crawl your page again, they have a debug tool at https://developers.facebook.com/tools/debug/ to show you exactly what they see when someone links to your page.
Richard


(Gabrielle Vickery) #4

Thanks for that Jannis ;-). And thanks to you Richard, I did as you both suggested, I put in a new logo jpg, then copied all the code including my jpg title and put it in the header field. But now when I go to that debug page it’s a blank pic instead of the new logo showing up (see attached). So I’m still not quite doing it right?


(Jason Bostick) #5

+1 for that link! Very handy


(Richard Nicholls) #6

Looks fine now Gabrielle.
Maybe fb needed a moment or 2 to scrape it.


(Gabrielle Vickery) #7

Hey Richard, thanks for that. It’s a bit confusing. That logo shows up massive in your screen grab so I’ve reduced it and rescraped, but now what I get is this, I did this yesterday but it’s not seeing a logo at all:

.

Can you help?


(Richard Nicholls) #8

Indeed.
The image link is wrong.
It says http://www.stormdesignprint.com/STORM-GREEN-LOGO.jpg but if you visit that address there’s nothing there.
Once you’ve found it / uploaded it you might just have to change the width and height tags to make it fit, that’s all.

Richard


(Richard Nicholls) #10

Bear in mind also that fb can be a bit temperamental.
I make a regular podcast that has a new RW page for each episode and often the fb scraper doesn’t show the image, but it is displayed when shared.
I do a test share to my own fb wall to make sure it’s working, and change the privacy settings to 'Only Me"
I just tested it with yours and it showed fine on my fb wall, yet didn’t display it on the debug page, very odd.

Richard


(Gabrielle Vickery) #11

Thanks so much for testing that. I’ve tried with 2 different logos now, uploaded them separately to ftp just to be sure, still can’t see it either in my facebook or in debug settings. Very annoying.

Happy that you can see it though. Thanks for taking the time to post screen grabs. :slight_smile:


(Doug Bennett) #12

Might want to take a look at this post:
facebook will Cache some data.