Facebook OG URL

Hi. I am having a nightmare with OG tags for Facebook. My homepage will only appear with an image in Facebook links if it has index.html appended to it, which obviously no-one ever writes it as. I noticed that the social tag generator specifies the URL with index.html so I tried changing it by adding the OG tags myself but still no luck. Any ideas anyone please?

The page is www.clphotography.co.uk but the image only appears with www.clphotography.co.uk/index.html

Not sure if this is relevant but I notice your URLs are appearing with .html appended. How are they defined in Rapidweaver?

The best way is to enter your page name in the ‘folder’ field, and index.html (or index.php if necessary) in the ‘Filename’ field.

Then make sure ‘tidy website links’ is selected in ‘Advanced’ (left side settings).

If you change these, best to delete your old pages from the server and then a full republish from scratch just so you don’t have a load of duplicate pages floating around. I’d be interested to see if this makes a difference.

1 Like

As LJ(@manofdogz) said, you are not using tidy links.

If the site has been up for a while and you want to maintain search engine rankings, references to current pages, and exciting customers that may have saved or bookmarked existing pages, then you’ll need to set up redirects from every existing page to the new URL addresses.

For example, the existing page and URL

Will become
With a URL of

Once you change the file/folder names and start using tidy links, any old link to the existing page https://www.clphotography.co.uk/portfolio.html would get a 404 not found once you make the change and delete the old page.


Good point Doug - lazy of me to forget the redirects!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.