Added favicon but not showing


(Craig) #1

Hi,

I added a favicon.ico in the general section of the settings but it is not showing in the site after publishing.

Any suggestions on how to get this to work?

Thank you


(Robert Ziebol 🖖🏼) #2

Couple of ideas.

  1. Have you cleared your cache??
  2. Are you using Cloudflare?

(Graham Jackson) #3

I have found on occasions that favicons take a while to appear. If it shows ok in RW then just give it a while. Have a day off & check tomorrow :slight_smile:


(Craig) #4

I cleared the cache and still not showing… I am not using Cloudflare.

Any other ideas…the favicon.ico is on the server in the site folder.

Does it have to be in the root (public_html) directory?

Thanks


(Craig) #5

Waited a day still nothing…


(Doobox Software) #6

@crugh How did you add the favicon image? Via Rapidweavers built in drop zone in the general settings section?

The icon should be at the root of the website, at the same level as the websites index html/php file. RW would place it there by default, and add the necessary code to the head of the page to enable the icon.


(Craig) #7

I used the built in drop zone and yes RW placed it at the website index.


(Doobox Software) #8

What’s the url? And what’s the favicon meant to look like?


(Craig) #9

The url is:
http://www.basslandscapingcare.com/site2/

and the favicon is:
http://www.basslandscapingcare.com/site2/favicon.ico


(Doobox Software) #10

OK, you are not Cached, because I don’t see your icon either in any browser.

So it really only leaves one thing in my mind. How did you produce the icon?
You did not just take an image and change the extension to .ico did you?

Even if you did use a web service or some other means to produce a true .ico file, it seems to me that its the only thing left to wonder about the integrity of, since you have checked every thing else is in place where it should be.

I happen to make an application called Rapidicons, that will produce a true retina ready favicon.ico file if you are in any doubt about that.

https://www.doobox.co.uk/apps/app_demos/rapidicons.html


(Robert Ziebol 🖖🏼) #11

This is happening because the icon is expected to be here
http://www.basslandscapingcare.com/favicon.ico
according to the source code and it is not there.


You do not need to purchase anything else, you just need to get it put in the right spot.


(Craig) #12

Thank you. It works. I changed the url to http://www.basslandscapingcare.com/site2/
in the general tab and it referenced the favicon in the right place.

Sorry for the confusion and thank you for all the support!!! I was making a demo site and tried to keep everything true to the original site before replacing it.


(Robert Ziebol 🖖🏼) #13

Makes sense. Glad you got it working. Have a great day!