Anyone use MachForm with Little Oak hosting?


(Mary Delton) #1

I have a RW built website and made some forms with MachForm. I want to test them before going “live” but I can’t get the email notification to work. I submitted a ticket to MF but thought I’d ask here because I thought someone might be using Little Oak and would be able to advise me of the SMTP settings to use. I’ve tried all the variations I can think of but haven’t had any success.

TIA
Mary



(Mathew Mitchell) #2

I use MachForm a lot and have never had any problems with notifications. I use ChilliDog hosting. However, I’m not sure this is a hosting issue.

In MachForm I have things set up to send responses to one of my Gmail accounts. It works fine as is. This means I have the option to “Use SMTP Server to Send Emails” unchecked. At MachForm it says to use if your form does not get sent to your emails to add this feature on. So originally were emails not being received by you?

… and you’ve set up Notification Settings for each specific form? (I realize the answer is probably yes, but just being careful.)

It also might be useful to post the example form.


(Mary Delton) #3

@Mathew. Thanks for your reply.
In MachForm I have set up the form notification to go to my webmaster account which is aliased to my personal email and it works from the website. I tried both with SMTP off and on. If “off” I get the “Congratulations, your entry has been sent” message but no email arrives.

If SMTP is “on” I get a long error message. I am only testing one form right now so only have notifications set for that form. You can see the example form by going to www.gvrdc.org, click on GVRDC SHOWS and then click on the button near the top left for “Entry Form” which will take you to the entry form in question.

Another question - I have a required signature box and it says you can type or draw your signature. How do you enable it to type?

Mary


(Mathew Mitchell) #4

Mary:

First: I don’t see any option to type a signature. I’m not sure where you are seeing that. I just see drawing a signature. (If you wanted to type you could use another form field.)

Second, I’m not sure what the mail problem is based on your description. I suppose the alias part could be throwing things off. Why not try having email sent directly to your personal email in MachForm settings? Try that out and see if it works. There are several options with the “Send Notification Emails to My Inbox” area so I’d carefully go through all of them. For example, I suppose it’s possible the “From Email” setting you are using might be the problem. There are little help/question icons that give further info about using each of the fields.

Sorry I can’t be more helpful. And it simply may be an issue with your hosting company, or perhaps even your email client. But it’s worth making sure everything on the MachForm end is working fine and is set up best first.


(Mary Delton) #5

Matthew
As to the typing or drawing of the signature, it’s weird because I added that field to my form weeks ago and it distinctly said “draw or type”. I just went in and added a new signature field and now it only says “draw” Maybe they just changed it - just weird.

I have tried sending the mail notifications to a variety of email addresses (my personal as well as other web addresses that I get mail from). If SMTP is not checked, I get the “congrats” message. If SMTP is checked, I get a very long error message. I haven’t heard back from the MachForm support person yet. Hoping he can figure this out. I will go into the options under SMTP and make some changes (so far I left them as default) and see what that does.

Thanks again for your thoughts on this problem.

Mary


(Mary Delton) #6

@Mathew
Happy Happy Happy! I finally found the problem. It was a very simple typing error in the forwarding email address. Turns out I have to check the use SMTP. But in order to discover that I made about a hundred changes in the various settings. Funny how something can be misspelled but you can look at it and not see the misspelling because you read what you think it should be.


(Mary Delton) #7

Just to clarify…not quite as simple as I made it sound. In addition, I had to make a new email address on my server to accept a php form. My website address of webmaster@domain.com can still not be used for the notifications in the form from MachForm. I can only use my personal email or info@domain.com.

Perhaps this is the same for other servers so I thought I would post this in case someone else runs into what I did.

Mary


(Mathew Mitchell) #8

I’m glad you found a solution! MachForms is very nice to work with so hopefully it will be smooth sailing from now on.