Armadillo Doesn't Load onto Website -Blank Page


(RK Rossi) #1

I’ve uploaded the completed website to the client’s website and Armadillo isn’t loading. All I see is a blank page.

I followed the instructions for when you see a blank page and that didn’t change a thing.

Suggestions?

I can see everything else on the website just fine.

Can you use an Armadillo Blog as the first page on a website? That’s where mine is right now. I could place it second and have tried it there, but it doesn’t make any difference. I see a blank page.


(Jonathan Spencer) #2

Mmmm, the latest version does the same for me. It worked fine for several blogs before I upgraded.


(Brian LaPan) #3

Armadillo is still working perfectly for me since the update. Perhaps drop Yourhead a support notice https://www.nimblehost.com/contact/


(RK Rossi) #4

I got the page uploaded after several tweaks of certain things required by the hosting company; using the IP address instead of “localhost” for the DB Host.

I discovered that the side bar code was somehow not functioning right. I deleted it and dragged over the snippet again and told RW to ignore formatting.

However, now I see this odd thin white line below the page. It’s only on the blog page.

http://kathrynbrettell.com/page0/page0.php

The upgrade was already on my computer for this site so I don’t have anything to compare it with.


(Jonathan Spencer) #5

It looked just fine to me with no lines to be seen.


(Terry Norton) #6

I do see the white line.


(RK Rossi) #7

I updated the site and on the RW software there’s no sign of the odd line, now lines, showing on more than one page.

However, the lines show up on the website. :confounded:

I don’t know if this a RW thing or an Armadillo thing or both.


(Brian LaPan) #8

Armadillo has new code for the sidebar included in the new update. Make sure you’re not using the old snippets.


(Jonathan Spencer) #9

I now have a semi functional page but can only show new pages and the blog entries don’t appear at all. This is on a new page in a new project so only using the latest stacks available. I have sent a email to their support and they are looking at it so will see if it is me or not soon.


(Dick Sijtsma) #10

Hi, after updating the Armadillo page, you might want to check all the things on the server. Go in there with an FTP client and check out the rights and the ownership/groups of the files. Try to change the rights for example to 777 (unsecure!) and check if the blog works. If it is working, try to reduce the rights, until the level the blog isn’t working anymore. In my case, i had to give 775 to get it working.
I was able to access the server with SSH too, so i could change the group some of the files belonged to. This helped too. But not all hosting providers offer shell access.

Did you perform the updates, after logging in into the backend of Armadillo?


(RK Rossi) #13

I have the most up-to-date version of Armadillo. I used the sidebar code included with it. I created this website after I upgraded Armadillo.


(RK Rossi) #14

I messed around in the server with Armadillo using CyberDuck when the problems first arose. I changed the rights from 644(?) to 755 (?). And thought that solved my problem. It didn’t. I’m thinking of changing that back to the original number. It was the issue with the sidebar. After fixing it, my blog page uploaded fine.

The only remaining issue is the extra lines on the pages.


(Jonathan Head) #15

Sorry you ran into this issue @Scribe. Just to clarify, to make sure I understand correctly, the problem was using an older version of the sidebar snippet with v1.7+ of Armadillo, correct?


(RK Rossi) #16

For this website, I never used the older version of Armadillo’s sidebar snippet.

When I told RW to “ignore formatting” it didn’t work because the snippet code was not properly highlighted. That was my gut feeling. So I just deleted the snippet code and started fresh. Afterward Armadillo loaded just fine.


(Jonathan Head) #17

Thanks for the clarification. :slight_smile: