Armadillo Slim application error


I updated to Armadillo 2.9.5 and got a Slim application error message as shown in the screenshot.

Don’t know whether these 2 other problems are related to this:

  • Inline editing is not working as it should, neither markdown nor Rich Text is available, just HTML code;
  • Preferences cannot be changed or updated

Anyone else with this problem?

I updated to 2.9.6 but the issues remain…

I manually installed a backup folder and this error error disappeared… after running a backup for the database I get this error now:

Code: 8

Message: A non well formed numeric value encountered

File: /var/www/

Line: 1845

I could solve one issue. After manually deleting the backup folder, created a new, empty one and DID NOT run a database update. Now, I can change and updated all preferences.

However, the Basic and Rich Text Editor don’t work for inline editing (neither Safari nor Chrome). Markdown seems to be ok when there are no images.

Tagging @nimblehost

After updating, did you perform a full republish (the Re-publish All Files option in RapidWeaver) and clear your browser cache? If not, that would be my first recommendation. As for the other issues:

  • For the Slim Application Error, the screenshot references “mkdir()”, stating permission is denied - this can mean either your hosting account doesn’t support the use of mkdir() for PHP applications, or the “user” that runs PHP applications on your hosting account is unable to run such commands via PHP scripts. In either case, this isn’t something caused by Armadillo. I’d suggest contacting hosting support for more information.

This is not something I’ve encountered before. What version of PHP are you using?

As for the content editors not appearing, this can potentially be fixed via the first steps I mentioned above regarding publishing and clearing your browser cache.

Hope this helps.

Hi Jonathan

Thanks for your reply.

Yes, I did everything according to your documentation (re-publish everything, clearing browser cache etc.).

I contacted the person responsible for the hosting (the concerned site is for customer where I don’t have access to any server configuration) who cannot explain the error message, too.

I resolved the issue ‘mkdir()’ by creating a backup folder manually. However, after having run a backup the other error shows up (non well formed numeric value) and the possibility to updated the preferences fails again.

The content editors are working fine in the backend but still fail to function for inline editing.

Cheers, Juergen

PHP is 7.2.24

Which theme are you using? Also, I just release v2.9.7, which fixed an issue with image resizing control for the live page Solo Content editor. Are you still seeing the editor issue after installing that latest version?

Hi Jonathan

Thanks for your reply. I am on 2.9.7 already and the issue remains: no Rich Text Editor for inline editing.



Hi Jonathan

I forget to tell that I’m on Foundation 6.x.

In your documentation, you mention to upgrade the database after republishing all files but you do not describe how to do that.



Thanks for the info, Juergen, I’ll try to reproduce in Foundation. There’s no database update needed for v2.9.7, but should any be needed in future releases just login to the online dashboard and a banner will be displayed there.

I’ve just released v2.9.8 which fixes this in themes which load scripts at the bottom of the page, like Foundation.

None of the recent releases require any database upgrade. Should one be needed, a banner will be displayed in the online dashboard the next time you login.

1 Like

Hi Jonathan

Thanks a lot - that solved the problem. So, Armadillo is almost perfect…

The only thing I miss so far is to apply categories to content (solo) and media. I am working on a multilingual site (4 languages) with many solo content blocs. It would be helpful to group the content and the media as well. So far I remember, this is on your list for 3.x?

Best, Juergen

It’s me again… I just noticed that Redactor does not seem to use the corresponding language file. English remains even if you switch to another language in your profile.

This wasn’t the case beforehand

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.