Button Links not working


(David) #1

I may be doing something wrong. I cannot get this button link to work:

The New Post page is a subpage of the Admin page:

09%20PM

Thanks to all.


(Doug Bennett) #2

From the screenshots, it looks Alright. You seem to have to buttons with the same name? The link appears to be set to page, and then you selected the “new post” page. There is only one “new post” page?

What is it doing when you say “not Working”?


(David) #3

I’ve tried with two buttons. Only one at a time. When I tap the button, nothing happens.


(scott williams) #4

Do you have a url for that page? (The one with the button)


(David) #5

Good thinking. I’ll test that…


(David) #6

Seems ok : https://bohtech.com/beatriceCMS/admin/blogForm.php


(Joe Martin) #7

do you have the open in new page selected…it won’t work in preview!!


(scott williams) #8

Okay, first off, you should leave your page’s file named index.php
As it is now the admin page and the blogform page are in the same folder, that’s not what you want.

Name the folder not the file. So if the admin page is …/admin and the blog firm is a sub-page of that, It would be …/admin/blog-form/index.php. Just leave the file name as index.php and naming the folder will give you urls that are better for SEO and easier for users to remember.

Start with that, and republish.


(David) #9

OK. Thanks. I’m having a bit of a hard time republishing. I republish all but after - copy the link in the button, and it shows the old link…

I’m visiting my family so maybe the internet connection is not as great as at my home… I’ll keep persevering.


(David) #10

Ok, I’ve changed the link in the button (top one) to: https://bohtech.com/beatriceCMS/admin/blog-form/index.php

Still no joy when pressing the button…


(Joe Martin) #11

Isn’t that an admin page?


(scott williams) #12

It looks to me like The button url is pointing to the page it’s on, not the blogform page, but I’m on my tablet so no dev tools


(David) #13

it is


(Joe Workman) #14

None of the links that you posted here are working for me.


(David) #15

Sorry. I changed the URL as suggested above… It’s:

https://bohtech.com/beatriceCMS/blog-form/index.php


(Joe Workman) #16

it seems to work for me. I didn’t so anything special. I just typed in “test” into each field.


(David) #17

Yep, when I copy the URL, and paste it into a browser, it works. But I just can’t get the Button > link to work. I’ll lol more tomorrow. But I’m really open to ideas. D


(scott williams) #18

Your admin page (with the Add New Post button) is here: https://bohtech.com/beatriceCMS/admin/
The button links Here: https://bohtech.com/beatriceCMS/blog-form/index.php
Which is now correct from what I can tell. If I click on the link in the source it works, if I click on the button it’s self it does not.

What say You @joeworkman ?


(Joe Workman) #19

You seem to have the entire page inside of a CMS Save stack. Don’t do that…


(David) #20

Joe, that was it. Many thanks

David