Links on buttons


(B.V.Valeur) #1

I have a page on my site with various Buttons, each giving a link to a photo gallery in SmugMug. This has worked without problems earlier, however, somehow two of the buttons get the same link as it’s neighbour on publishing i.e. two buttons link to the same gallery. Checking the input, everything looks fine. Additionally all my buttons disapear on publishing, leaving only the text (containing the link).
Any ideas on how to solve this?
I run RW6.3.8, the theme is Stream2.1 and the button is under Content. Each button is placed in Adaptive Grid.


(B.V.Valeur) #3

Thanks your response, however, I have to admit that I do not understand what you mean. The way I do this is simply copying the unique link attached to the particular gallery, hitting the “set link” and pasting the link into the box in which there is already a blue coloured # which disappears when pasting.
What else can I do? I have previously done this many times without problems.
There is also a question of why the BUTTONS disappear on publishing, leaving only the text on the webpage. Additionally, I’m suddenly unable to publish. I try to add text which is saved in RW but do not appear on the web.


(Waleed Barakat) #4

What i mean is duplicate style name may cause such problems! Anyway have you tried to clear your browser cache? it might be a cache problems specially if you’re using “Cloudflare” you have to clear it from cloudflare.com or from your Cpanel within your server.

Also try to test it in another web browser or via online program to see where is the problem occur.


(B.V.Valeur) #5

Cashe is cleared and I have tested it in a different browser. No change. Buttons do not show, links are correct as set in RW, however, the same links are wrong as before and finally publishing is not possible (no error message appearing). Have you been checking my site in RW?


(B.V.Valeur) #6

Can I expect any further response from you on this ?


(Brad Halstead) #7

@bamse6540

Looked for a URL to your issue and could not find one…

Could you be publishing to the wrong directory on your server? RapidWeaver doesn’t say finished publishing unless it actually has.

Did the pages in question change from .html to .php by chance? You would have to use an external FTP program to check the server for correct version and delete the un-used one (MOST hosts serve the .html file before the .php file therefore if both exist the .php file is ignored.

Are you running RapidWeaver from your Downloads folder or your Applications Folder? (May be a stupid question to some but many a person has their browser configured to extract files, then they run the app from the Downloads folder which causes a MESS!)

Do yours CloudFlare for SSL spoofing?

Other than that cannot give more details without a URL

Brad


(B.V.Valeur) #8

Thanks yours. Mys site is www.gambay.net and I should be very happy if you could take a look at it. Although the site contains few if any secrets it is password protected therefore kindly give me your direct email and I’ll send you the password. Thanks in advance for your interest.


(Brad Halstead) #9

@bamse6540

Just to keep the forum up to date…

  1. There is at least one folder with an index.php and index.html inside it, the index.html one seems to be the correct one for the albums but I could be wrong. If the PHP file is the correct one, then the grid is not showing. Server serves index.html priority over index.php.

  2. There are 2 pairs of links that have the exact same links each - it doesn’t look like they are ‘joined when making link’ as they are separate stack entities.

For both issues, I have suggested a wipe of the server to clear duplicated files with different extensions, verification of the link to the proper url and republish entire site.

Anything else develops will keep you posted.

Brad