Links not working as I want them to


(Ronnie West) #1

I though that I had this topic worked out but, I only got it half right:rolling_eyes: On my website, I have a Tutorial index with some internal links to the various tutorial pages. I used a ‘Button Group’ and linked each to a tutorial page. It all works great but those buttons will only work in a sequential way, i.e you can click on page 1 then page 2 and then page 3 you can then go backwards in the sequence 3 to 2 to 1. However, if you attempt to to go from 3 to 1, then you get an error message ‘Page cannot be found’ (obviously)

Is there a way (or a stack) that will allow me to to navigate so that I can click on page 1 and go to that page, even if I am on Page 3?

I may not have explained this very well so please go to my site and check the ‘Tutorial Index’ page

[http://www.ronniewestphotography.com]


(Mathew Mitchell) #2

It unclear to me what you really mean. So, does the problem exist on this page:
http://www.ronniewestphotography.com/page-3/page-15/

If so, what are you using to create your buttons?

The naming conventions you are using may not be the cause of the problem, but they aren’t very helpful. For example it probably makes more sense if:

  • page-3 is tutorials
  • page-15 is rapidweaver

… and then you have part1 or page1 etc. for various parts of rapid weaver tutorials.


(scott williams) #3

When on this page:
http://www.ronniewestphotography.com/page-3/page-15/

the Button [Page 03] links to: " href="…/…/(null)/(null)"
And you get a 404 when trying to go directly to page linked by the Page 03 button

When on this page: http://www.ronniewestphotography.com/page-3/page-18/ (the page linked by the Page 02 button)

That same button links to:
href="…/…/page-3/page-20/"
This works

I can’t find any other broken ones, only the link on the Page 03 button if setting on the “Page 01”

FYI you would be much better off naming your pages more descriptively and with keywords as mentioned by @Mathew above.

Edit I just noticed if already setting on the [Page 03] page the button for that page also has the same error as above. (not really sure why the button is even there for the page you are already on but I guess since it is there you should fix that one also)


(Ronnie West) #4

Hi Scott,
Many thanks for your comments and your suggestions.
I have used the link system supplied within RapidWeaver so don’t really understand why the links are getting confused.
The problem I am seeing is that, when on page 03 and then try to link back to page 01, I get the failure message. Try it and you will see what I mean.
Maybe I should not use buttons/links at all but think of another way of achieving the result I am looking for.
Regards, Ronnie West.


(Ronnie West) #5

Hello Mathew, Thanks for you help and I am sorry that my post appeared to be unclear.
Yes indeed, the problem does exist on the page you mention, if you select Page 01, the link works perfectly then if you select Page 02 it works again, then select Page 03 it works OK again. Now, while Page 03 is selected, now select Page 01 and you will see the error message.
I am not clear on why you have mentioned ‘page-15’ though.
As far as the the buttons are concerned, I used the RapidWeaver found in the Library.


(Mathew Mitchell) #6

This morning the links on that page, used in the sequence you suggest, are working just fine.


(Ronnie West) #7

Hi Mathew, I cancelled the old links and re-linked them all after making a couple of changes e.g. Page 1 to Page 01 and it seems to have made the difference. Fingers crossed!

p.s. In the meantime I downloaded the ‘MyMenu’ stack to try but am having some trouble setting it up. I watched the video that they have on the website, but that didn’t really help. Do you know of a website using this stack?


(Ronnie West) #8

oops! Seems like I got to confident because although every sequence I tried was perfect, attempting to go from Page 01 to Page 03 does not want to work.
Back to the drawing board I guess.
Ronnie West.


(Ronnie West) #9

I think I found the problem, it was an incorrect link - I had set it to Page 3 but it should have been Page 03. Silly mistake on my part.
It all works great now, fingers crossed!
Ronnie


(Theophilus) #10

Please, what’s the link to download MyMenu stack. I lost the download link when my system was formatted. Thanks