Cannot publish my RW6.4 site, have tried everything - Help!


(Dave King) #1

I have a small site which I have added new items to but they won’t publish. The site has been online for several years without any hitches and I’ve applied changes successfully before.
I’ve tried ‘republishing all files’, my server settings are correct AFAIK, RW goes through the motions of publishing normally but nothing changes (I check using Cyberduck and the files haven’t updated at all: I’ve refreshed browsers, cleared caches etc).
I’m using ftp: I’ve changed to ‘Active’ mode, changed to slowest concurrent uploads, etc - no change.

I’m not an advanced web designer by any means and would appreciate any assistance (which I can understand). Thanks in advance.


(Rob D) #2

First of all, if you are using High Sierra OS, the oldest version of RW that is compatible is 7.5.

If you are not a frequent user and you do use Cyberduck, as you said, why not just do a local export and then use Cyberduck to transfer files to your server? This is a preferred method of publishing for many of us.


(Robert Ziebol 🖖🏼) #3

This is not quite true, the oldest version of RW that is supported by Realmac is 7.5 with High Sierra, but I use RW 6 everyday in High Sierra, and as long as I preview in a browser to not get the preview bug, RW 6 works very well for me.

Since you are already using Cyberduck to check files, why not publish to a local folder and upload that way. I know not the easiest way to do it, but it works. Also, not sure if Cyberduck has this option, but if it does, you could sync that folder with the folder online (Transmit does this and others as well) so when you export to a folder, it syncs the online folder, so when you make changes they get made online.

One last thing, I am sure this is not it, as you are checking on Cyberduck, but when I saw you say this:

RW goes through the motions of publishing normally but nothing changes

Do you know if your filename has changed from index.html to index.php?? If so, RapidWeaver does not delete the unwanted file. If you have both, most servers will choose the index.html file over the index.php file, and if your changes are going to index.php, you might not be seeing them. Just something else to look into.

Good luck!


(Dave King) #4

Thanks for these answers. I’m actually on the newest version of High Sierra so that may be part of the problem.
Could one of you explain how to ‘publish to a local folder’? Thanks

I’l check the other things re php/html when I get a moment. That has been a problem in the past, I seem to remember.


(Robert Ziebol 🖖🏼) #5

My fault, I did RW 7 publishing to folder. As @swilliam mentions below, you want to go to File and down to Export Site.
16%20AM


(Doug Bennett) #6

Robert (@zeebe),
Isn’t this RW7 way of publishing local. I don’t have RW6 anymore but I thought you exported from the file menu if I remember?


(scott williams) #7

Doug (@teefers) is correct, in RW6 I believe you just select Export SIte from the file menu.


(Robert Ziebol 🖖🏼) #8

Crap, you guys are right, sorry, I had RW 7 open and was just jumped in and did it this way. My mistake. Will delete the info above.


(Dave King) #9

OK, thanks for all your help, I have exported site to a Folder on my Mac I’m calling ‘Test’ - how do I upload it from there?

Here’s Cyberduck’s opening interface:


(Dave King) #10

Just bumping this because I’m still stuck (see above post). Thanks in advance.


(Gabrielle Vickery) #11

Hey Rovertek, why are lots of people exporting rather than just publishing in Rapidweaver? It’s much easier to just hit publish isn’t it rather than export the site somewhere and then manually upload?


(Doug Bennett) #12

I never have used Cyber Duck, but while you want to do is connect to your host like you did to check files. then upload the files from the folder you exported into to the host.

The screen shot doesn’t mean much to me, most FTP clients I’ve used have at least two windows one for your Mac and the other for the server.

Perhaps the help from cyber duck would help:
https://trac.cyberduck.io/wiki/help/en/howto/upload


(Robert Ziebol 🖖🏼) #13

It does not look like you have the FTP app setup to your server. Never used CyberDuck so not sure how to do that, but follow @teefers suggestion and read that help from CyberDuck’s site.


(Dave King) #14

Thanks for all your help. I managed to get Cyberduck to upload all the files but it still didn’t work…

Finally after a couple of weeks of trying I managed to speak to my webhost who informed me that the path (/…) to my server had changed, but he hadn’t bothered to tell me, even though I emailed him two weeks ago to check that all the FTP settings were still correct…:roll_eyes:

…and now it all works perfectly, of course.:rage:


(system) #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.