Can't publish after 6.3.5 update


(Tim Lawson) #1

Following an update to RW 6, version 6.3.5 (from version 6.3.4), I can no longer publish my sites! I get a message saying: “Couldn’t upload to your SFTP server: Failed initialization” This was working perfectly prior to the update. Restoring version 6.3.4 allows publishing as expected.

I’m running OS X 10.11.1


(Don Sinclair) #2

This update is a disaster. It is trying to publish my site this morning with about 24 changes and insists it has to publish 638 files. Normal upload time for my daily update is 90 seconds and it has been running now for 54 minutes. Good grief RW, take this mess off the table and try to figure out what is wrong with it.

Me? I will now hope Time Machine can bail me out of a mess that I had no part in creating.

Shame on you RealMac for a terrible job.


#3

I too am having problems publishing. I can publish a few times with no issue then, all of a sudden, the publishing window will hang will no progression. The fix for this is to quit RW and restart it. Annoying.


#4

I also had an upload failure earlier but then it worked the second time. This has been a common experience though under all versions of RW6.


(Don Sinclair) #5

I used Time Machine and reverted to RW 6.3.4 and just 23 files went up in seconds.

Stay very far away from RW 6.3.5 unless you wish to inflict major issues on your RW files.

This sure points to a huge mistake in testing the update before foisting it on an unsuspecting user base. A real black mark on RealMac.


(Robert Ziebol 🖖🏼) #6

Not sure it is a real black mark on Realmac, as they freely provided betas for 6.3.5 here on the forums, if enough people didn’t test it and find these issues, I would say that is on the user base. I have been lucky and have had very minimal issues with RapidWeaver 6 since 6.0, so I have had no reason to beta test any of the updates since then, but if you have issues, I would be testing every beta and providing the best feedback to Realmac as you can.
Just my 2¢.


(Don Sinclair) #7

Sorry, but when a company issues an update for a program I pay to use, the onus is not on me to test their software. That is RealMac’s responsibility to their client base period. The black mark comment stands as far as I am concerned.


(Oscar Schmid) #8

Here no problems with RAW 6.3.5 and publishing. 6.3.5 is a beta.

If problems do arise, you can download the older versions of RW at any time here.

I rename every new version after download. So I can quickly go back :wink:


(Tim Lawson) #9

Nonsense, @Zeebe. It is not - never has been - incumbent upon paying users to also be beta testers. Think about what you’re saying! Should all Volkswagen drivers have tested their vehicles so as to discover whether or not they were equipped with dodgy software?


(Robert Ziebol 🖖🏼) #10

Yup, let’s compare apples to oranges.

Yes, it is on the company to release non-buggy software, but publishing has a lot to do with the servers people are using as well as the software, and if people are not testing betas that are FREELY AVAILABLE for people to test, then Realmac is not going to know of issues that are happening with all available hosts.

Also @TimLawson, are you saying Realmac has intentionally did this as the people at Volkswagen did??


(Tim Lawson) #11

No… 6.3.5 is not a beta. It comes up if you click on the ‘Rapidweaver>Check for updates…’ menu item. If you have previously checked the ‘Automatically download and install updates in the future’ box, then Rapidweaver does just that. Version 6.3.5 is also on Macupdate.com website and doesn’t show as a beta.


(Robert Ziebol 🖖🏼) #12

Again, you missed my whole point, IT WAS FREELY AVAILABLE FOR BETA BEFORE RELEASE. Has been for weeks here on the forums. Just like I am sure 5.3.6 will be available when they have it ready for testing.


#13

Utter tosh!

A great bunch of people who are using RW are not edge of the seat beta testers but have paid for, and expect, a solid application that delivers what it promises. Uploading via FTP should NOT be an issue at this point and this is not a fault of the user base. FTP was fine for me in RW 5.x but I’ve had constant issues in RW 6.x. Do i have this problem with any other web or FTP software? No. Only RW.

Just my 2 pence.


(Tim Lawson) #14

Fair point @Zeebe (re. hosts) although you did not qualify that in your original post. Further, I too have had no issues with RW6 until now, so there was no reason to suddenly think of beta testing. A lot of - probably most - users would not think of or wish to beta test software or even read the forums if they hadn’t previously experienced an issue. Where do you draw the line? Should we beta test all software we use?

And no, I am not suggesting that Rapidweaver intentionally did this, and you know it.


(Robert Ziebol 🖖🏼) #15

@doone128 Have you ever used any of the beta’s they provide for testing? Have you ever sent in project files and info on your host to Realmac? Without this, it can’t get better. You guys have it wrong, I believe Realmac has a blame in this, but if people are having issues, and only reporting it here on the forums and not giving info to Realmac, then you are not helping them get to where they can fix it.


(Robert Ziebol 🖖🏼) #16

No, I am not saying to test all beta software, UNLESS you are having issues. That is what I was saying.


(Oscar Schmid) #17

This, I did not know, because for me this update has never worked through RW.
On the RW site is still 6.3.4 the latest version.

Edit: Now it’s RW 6.3.5 :wink:



(Tim Lawson) #18

FWIW, I emailed Realmac last night (UK time as I’m a UK resident as I believe are the Realmac devs) to alert them to the issue I’m having with 6.3.5. Haven’t yet had a reply.

And I think you’re missing my point - I wasn’t having issues until this one reared its head.


(Tim Lawson) #19

@Oscar… this is what happens every time I launch 6.3.4 since yesterday which is what alerted me to the issue having gone ahead with the install. Having reverted to 6.3.4, publishing works just fine for me.


(Robert Ziebol 🖖🏼) #20

No, I got it. Like I said, do not use betas unless you are having issues, you are, so my guess is for you to use the betas when they release them, if you want to help the next version to not have these issues.