Cannot SFTP into newly built server

I setup a new web server for myself this week. It’s running Ubuntu 8.10. Today I configured the credentials into RapidWeaver and its just not working at all. I have use the username and password and also tried SSH keys.

I can SFTP from terminal and from Transmit. Let me know what information I can provide so that we can try to get this fixed. This is my server so I have full control over everything.


Hey @joeworkman, what version of RW are you using? Also, which FTP server do you have installed on your Ubuntu server?

Hey @joeworkman, quick q, have you managed to connect with Transmit?

Yes. I can connect with Transmit and via terminal.

Here are the versions of OpenSSH installed

openssh-client/now 1:7.7p1-4ubuntu0.3 amd64 [installed,local]
openssh-server/now 1:7.7p1-4ubuntu0.3 amd64 [installed,local]
openssh-sftp-server/now 1:7.7p1-4ubuntu0.3 amd64 [installed,local]

This morning I realized that I disabled authentication with passwords. You can only login with ssh keys. If I enable password authentication, RapidWeaver works! Yeah! However, logging in with keys is not working.

Why does RW ask for both the private and public keys? Other apps only ask for my public key path? When I try to only supply a public key to RW, it requires that I type in my passphrase for the key. My key does not have a passphrase. When I use both private and public keys, it does not work.

This is the first time the I have ever tried authentication with keys. Let me know what I can do to help out.

I created an account for you on my server if that makes it easier for you to test out.
username: realmac
password: realmac

Hey @joeworkman,

I can’t recreate this at all.

I’ve had a Debian based server for years that uses a custom port & key authentication, password auth is disabled. It’s worked with RW since version 7.

I also have a newly installed Ubuntu 18.10 VM using the same OpenSSH versions as you have. I copied the pubic key on my local machine

cat ~/.ssh/

And appended it to the authorized keys file on the Ubuntu VM.


I made sure the permissions are set correctly on the .ssh folder

chmod -R go= /home/tom/.ssh
chown -R tom:tom /home/tom/.ssh

Now I can use terminal to access the server with

ssh tom@Ubuntu-VirtualBox

I configured RW like this and it connected without issue

1 Like

So you are providing a private key but not the public key?

I know that my keys work. I use SSH keys to get on my server everyday. I also use my keys to connect via Transmit. What can I do to see why it’s not working in RW? Are there any logs or debug info that I can test out?

Yeah so the setup is like this
Server: public key in authorized_keys file
RW: Configured with private key

I’m not sure why RW asks for the public key too, I think it’s a historical thing. The public key can actually be generated from the private key, which is what happens if you don’t specify one. The public key field will most likely go away in a future version of RW.

You could turn on RW’s upload logging in the Publishing preferences, try connecting then choose Copy Support Logs from the Help menu. Scrap that, I’ve just noticed a bug that prevents this from working.

There should be log files on the server that might help. Try running this and then perform a connection test from RW.

tail -f /var/log/auth.log

This is the only message generated in my logs on the server.

Connection closed by authenticating user joeworkman port 53626 [preauth]

Googling that didn’t really help me at all…

Could you try to see if it works for you on my server?

Ok, so I copied my public key into


Fired up RW, configured the publishing destination and it published first time without issue

Well shiiiiitttt. Good for you… annoying for me :joy:

Haha yeah, gotta be one of the most annoying things when it works fist time for someone else!

@joeworkman give the new build a whirl if you’re still having issues, maybe it’ll work…

Strange. Still not working. I see that you removed the public key setting.

I have tested on both my MacPro and MacBook Pro. Both Mojave. Both with the latest beta. Both machines work with Transmit and Terminal.

I guess I will just have to use password auth. I am all for helping figuring it out if you want to spend the time. Your call.

I will test with that realmac account that I created…

I tested the realmac account and its not working for me inside RapidWeaver either. :man_shrugging:

@joeworkman Can you list the steps you used to configure key authentication for the realmac account, and screenshot your settings in RW too?